MULTIMEDIA (BCA-11)

What is multimedia:-
It produces virtual reality in which sound, text, graphics, animation and video create effect of reality by

means of multimedia hardware and software.
Or

Integration of animation, audio, graphics, text, and full-

motion video through computer hardware and software for education, entertainment, or training.
Or

Multimedia is the field concerned with the computer-controlled integration of text, graphics, drawings,
still and moving images (Video), animation, audio, and any other media where every type of information
can be represented, stored, transmitted and processed digitally.

A Multimedia Application is an Application which uses a collection of multiple media sources e.g. text,
graphics, images, sound/audio, animation and/or video.

Virtuality extends the interaction —oriented features of multimedia by the concept of cyberspace.

MULTIMEDIA=Sound+Text+Graphics+Animation+Video — (Produce effect Virtual reality)

TEXT  stittmages
Words & Numbers
Multimedia
Technology



http://www.businessdictionary.com/definition/integration.html
http://www.businessdictionary.com/definition/graphic.html
http://www.businessdictionary.com/definition/video.html
http://www.businessdictionary.com/definition/computer.html
http://www.businessdictionary.com/definition/hardware.html
http://www.businessdictionary.com/definition/software.html
http://www.businessdictionary.com/definition/education.html
http://www.businessdictionary.com/definition/training.html

e Power Point.

e Paint Brush.

e VLC.

e Win Amp.

e Window Media Player.

e Internet Explorer.

e Real Time.

e Photoshop.

e Coral Draw.

e Master Blaster.

e HP Director.

e Director.

e Premier.

e FLASH.

e Wave front.

e FrontPage.

etc.
Example of Multimedia H/\W-
DVD Digital video disk
CD ROM Compact Disk Read Only Memory

& @ @

Speaker
Woofer
QWERTY Key board/Multimedia Keyboard.

& @

Scanner.

&

Printer.

&

Web cam.
VDU(CRT/LCD/LED/PLASMA/PROJECTOR)
PLOTTER.

LIGHT PEN.

TOUCH SCREEN SYSTEM.

MODEM (Modulator And Demodulator).
MOUSE.

CPU.

BLU RAY DISC.

USB (Universal Serial BUS).

PEN Drive.

Mike.

A I A
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% CARD READER.
Etc.

Photoshop:-
It is used for editing images for industry digital imagine.

Wavefront:-
It is used for making 3 D tools for games, films.
FLash:-

It is vector based animation tools.
Front Page:-
It is used for designing web page.
Premier:-
It is used for making digital video.
Coral Draw:-
It is used for designing.
PowerPoint:-
It is used for making presentation, based on any topics.
Scanner:-
It is used for scanning images into digital form.

Window Media Player:-

It is used for playing video film.
Paintbrush:-

It is used for simple drawing.
Etc.

Extension Name/Secondary File name of Multimedia Software:-

.ppt  power point

.wav sound

.mov Video file

.VOC For Sound

.PCD Photographs stored in CD

.gif  graphics interchange format

Jjpeg image file (Joint Picture Expert group).
flc  (High Quality photographs)

.mff  (Music file).

.bomp  bit map picture.

.mp3 audio file.



Components of Multimedia:-

1. Textual Information
2. Images
a. (Bitmap Image)
b. (Vector Image)

3. Animation
a. (2D Animation) Two Dimensional Animation
b. (3D Animation) Three Dimensional Animation
4. Digital Audio
5. Digital Video
1. Textual Information:-

This component of multimedia can have various types of fonts and type sizes to suit the professional
presentation of the multimedia software.
Example:-1
Times New Roman
Tahoma
Verdana
ALGERIAN
Etc.
Example:-2
Word Art.
Font Color.
Style of Fonts (Bold, Italic, Underline).
Alignment (Left|Right|Center|Justify).
Format Painter.
2. Images:-
It is interesting components of multimedia. People do not like reading large amount of textual matter
on the screen. Image describe all information with respect to text.There are two types of images
a) Bitmap Images.
b) Vector Images.

Bitmap Images.

It consist of two dimensional squares, which are called pixels (Picture elements)
Or dots on the screen. Quality of pictures depends upon number of pixels.
Pixels are organized in rows and columns. One pixel consists of one bit.

0 Black

1 White



Example: - Paintbrush.
Vector Image:-
An image is formed as a set of straight line or curved instead of dots.
A line can be represented by mathematical equations, whose number can be stored as a
set of binary codes.
Example: - CAD (Computer aided design).
CAM (Computer aided Manufacturing).
3. Animation:-

An animation is just a continuous series of still images that are displayed in a sequence.

Types of Animation:-

1:-2 D Animation.
2:-3 D Animation.
2 D Animation: - It is pixels based animation, which produces flat images. There are two effect produces.
Morphing.
Warping.
3 D Animation: - It produces realistically portray with depth. It includes X, Y and Z-axis.There are three steps for

making 3 D animations.

Modeling Steps.
Animation Steps.
Rendering Steps.
Morphing:-It takes two images seamlessly changes one image to another.

Warping:-Image actually seems to grow out of the first one.

4. Digital Audio:-
Digital audio is always embedded in the sound to provide additional capabilities without
affecting the CPU.A common digital sound file existing in personal computers are known as
WAV files. The MIDI (Musical Instruments Digital Interface) sound saves disk space as it
only stores the instructions about how to play a musical instruments.It is two-way
transformation

Analog«——Digital

There are following components for audio and video.
Examples:-

Sound cards.



Speaker.
Mike.
Digital Recorder.
Voice speech Synthesizer.
Winamp.
Window media Player.
VLC(Video Lan Client Media Player).
Etc.
5. Digital Video:-
Digitized video is one of the many technologies used in the development of interactive multimedia. It
offers a wide range of flexibility as compared to standard video signal. The process of converting
analog video signal to digital video signal is called sampling.
Example:-
MPEG (Moving Picture Expert Group).
AVI (Abstract Video Interface).

Sampling Process

»

AN

Analog Video Signa i Digital Video Sibnal.
Difference Between CD ROM and DVD:-

PARAMETER CD-ROM DVD-ROM

DIAMETER. 120MM 120 MM

THICKNESS. 1.2MM 1.2MM

TRACK PITCH(Distance between successive turns of a spiral) | 1.6pM J4uM

Min Pit Length. .83uM 40uM

Laser wavelength. 780nm 640nm

Layers. 1 1,2,0r4

Data Capacity. .65GB 4.7 GB

Data Capacity (Per layer). .650 GB 4.7 GB single
side single
layer.
8.5 GB Single
side Dual
Layer
9.4 GB Double
Side Single

Layer.




Multimedia Design production and Distribution:-

All the development works are based on three basic principles.
¢ Planning.
¢ Design.
¢ Production.
+¢ Distribution.
Planning:-
During this phase, all the aspects of the related multimedia projects in
carefully thought about and planned.
Design:-
It is bridge between problem and solution. Designers are responsible for
providing multimedia system developers with complete and clearly out lined
multimedia features specifications.

Production of Multimedia:-

The process of creating the related media elements in a multimedia projects
including graphics, sound, animation and digital video is called production.

Distribution of Multimedia:-

All the elements are combined together using authoring software there are
bundled into a package and stored in various storage media for distribution.

Question 1:-What is multimedia?

Question 2:-What are various components of multimedia?

Question 3:-What is sampling process in multimedia?

Question 4:-What is animation in multimedia?

Question 5:-What are different types of images in multimedia?

Question 6:-What are different types of H/W and S/W for multimedia?

Question 7:-Differentiate between CDROM and DVD?

Question 8:-What are different types of multimedia extensions?



Application of Multimedia:-

In following area multimedia used in wide range. Such as
s Entertainment.
¢ Edutainment.
¢ Business Communication.
s Knowledge Transfer. (CBT) Computer Based Tutorials.
¢ Public Access.

Entertainment:-

Multimedia used widely in entertainment. Such as

a) Cartoon Film.

b) Movies Example Gravity, Titanic, Zoorasic Park, Ra One, Robot, End of
2012 etc.

c) Video Game.

etc.

Edutainment:-

It is nothing but educational entertainment.Many computer games with focus
on education are now available.
Example: -Sierra.

Business Communication:-

Multimedia is a very powerful tool for enhancing the quality of business
communication.
Example:-
Advertisement.
Video conferencing.
On Line Business.
Etc.

Knowledge Transfer:-




Such types of application involves transmission of piece of information with the
maximum impact.
Example:-
CBT (Computer Based Tutorial).

Public Access:-

Public access is an area of application where many multimedia applications
will soon be available.
Example:-
Tourist Information,
E-Ticketing.
Status Checking for reservation, passport, Pancard ,ATM ,E-Money
order,UID etc.

Multimedia In Publishing Industries:-

Multimedia in publishing industries used by following ways.
¢ Presentation of Information using text.
+¢ Publishing by using electronic Media.
*» By Means of tutorials (CD/DVD/BIlu Ray Disc of Amway Business).
s By means of www(World Wide Web/Internet).

Communication technology and multimedia services:-

There are following services may be included:-
+»» Basic Television services.
+¢ Interactive entertainment.
¢ Digital Audio.
+¢ Video On demand.

¢ Home Shopping through E-mail.



s E-Commerce. (On line share trading, Mutual fund trading, Commaodity Trading,
Bulian trading etc).

+¢ Digital Multimedia Libraries.

+¢ Electronic version of news papers, magazines etc.

Multimedia In Business:-

Multimedia can be used in many applications in business.
We will focus on the facilities with respect to business.

¢ Global Team.

¢ Voice mail.

% E-Mail.

s FAX(Facsimile Automated Xerox)

¢+ Audio conferencing

¢ Video conferencing

+» Document conferencing.

s E-Commerce Based Business.

¢ Website Hosting and Publishing.

Multimedia Pedagogues:-

It is interactive system for [eaching and learning. There are
following examples of pedagogues.
1:-Simulations
It is an important area of pedagogy where a student is engaged in
situations of problem solving. It is categorized into two forms.
A) Scenario Based simulation.
B) Knowledge based Simulation.
A) Scenario Based simulation.
It includes sound, graphics, animations, video etc.

B) Knowledge based Simulation.



This simulation based on text based knowledge information.
Example:-

Cardiac Tutor.

It was develoved by Chus Eliot, at university of Massachusetts, computer science
department. It provides following clues to the students.

¢ Spoken Advice.

“+ Emergency room sounds.

¢ Graphical indications such as ECG, MRI, CTSCAN etc.

2:- Multimedia Composition
These activities of pedagogues may include aspects like.
+» Creation of text, drawing, or digitized pictures.
+ Organization
¢ Access of documents, which involves searching of patterns and
indexing or filtering certain types of items.
3:- Multimedia and Explanatory Systems.
The explanatory systems who are using it can select the media for
displaying information.lIt consists of all types of media for

explanation.

Concept of Distributed Learning System:-

The process of learning and motivation for learning are influenced by a
variety of factors.
Following means are used for distributions
a) CBT (Computer Based Tutorials).
b) Distance Cooperation.
c) Real Time Communication.
d) Distributed data.



CBT (Computer Based Tutorials):-

Computer Based Learning, sometimes abbreviated CBL, refers to the use of
computers as a key component of the educational environment. While this can refer to
the use of computers in a classroom, the term more broadly refers to a structured
environment in which computers are used for teaching purposes.

Distance Cooperations:-

An important use for the World Wide Web is to support long distance learning,
also called e-learning, characterized by the physical distance of the student to the
teacher. Among all the existent technologies on the Internet, the Web provides the most
capabilities for distance learning.
Real Time Communication:-We live in an era of real-time — we expect to find
information when we want it, answers when we need them and access to find both of
these on our own. Self-service, social media, live chat, video conferencing and unified
communications and collaboration are all possible today because of developments in
real-time communications.
Distributed data in Multimedia:-
Distributed multimedia systems consist of multimedia databases, proxy and information
servers, and clients, and are intended to for the distribution of multimedia content over
the networks.
Question 1:-What are pedagogues?
Question 2:-What is Simulations?
Question 3:-What is cardiac Tutor?
Question 4:-What are various areas of applications of multimedia?
Question 5:-Discuss multimedia feature in business?
Question 6:-Discuss multimedia feature in publishing industries?
Question 7:-Describe about communication technology and multimedia services?
Question 8:-Describe about MEDNET system?

MEDNET:-



It is multimedia system which is used in hospitals and many diagnostic and
laboratories. It provides following services.

a) A real time monitoring and multiparty consultation.

b) Collaboration during brain surgery.

Meaning of Collaboration:-Collectively doing a particular work .There is no any

physical work presence.

Multimedia authoring Tools:- Most Important

Authoring systems are generally menu-driven systems intended to easy to use by the
multimedia developer. Authoring languages are specially designed programming
languages and have some distinct advantages over generic languages. By using
authoring s/w CBT become most effective.

Feature of Authoring S/w:-

1. Integrated Multimedia Elements.
It produces better interactivity and control over multimedia system.
2. Script Language Programs.
Script Languages are used for facilitating logical effect in multimedia system. It
consist of HTML, Javascript, VB Script etc.
3. lcon Based Programs.
Authoring s/w facilities icon based multimedia system.
4. DLLs for extending features.
Authoring s/w also facilitates extending features. With other multimedia
system.
5. Supporting CD ROM/DVD/BLU RAY Disc.
6. Supporting video for windows.
7. Hypertext.
It facilitates one file with another file.

8. Cross Platform capability.



It is an important consideration with authoring programs is their capability to
altered for presentation on Macintosh or Other H/W platforms.

9. Runtime player for distribution.

Example of Authoring Tools:-

1. Authorware
. Everest Authoring System

. Icon Author

. Macromedia Director.
. Quick Time

2
3
4, ImageQ
5
6
7. Hypertext

Authorware:-

This s/w facilitates multiple people to contribute to an application. Artist can load
a library with media, Programmers can provides templates for complex interaction and
interface designers can put everything together.
Authorware can run timers, change the flow in response to a user, keep score and access
laser disc via dialog box.

Everest Authoring System:-

This s/w is best suited for the developers of CBT applications. Who seek a
powerful but easy to use windows based authoring environment.

Icon Author:-

Icon author s/w is used for making icon based multimedia products.

ImageQ:-

This s/w is used for making presentation with highly interactive feature.



File saves with an extension .hkf files or .omp

Macromedia Director:-

It is better suited to multimedia presentations. It includes following features.
¢+ Timing Control.
+» Crossplateform capability.
s Animation features.
¢ Extensive architecture to add functionality.
Quick Time:-

It is a s/w developed by Apple that supports time based media on the macintosh

system. It stores video digital form.

Hypertext:-
This feature of hypertext includes linking of many files with each others.

F1 P | F2 P | F3

A A A

\4 \4 Y

F4 | 1r | | F6
Anchor tag:-

The anchor tag is used to create links between different objects like HTML page files, web site
(URL—Uniform/Universal Resource Locator).

<a href="HTML page files or URL”>Text or Graphics</a>



What is Hypermedia:-
An extension to hypertext providing multimedia facilities, such as those handling sound and video.

Or

Computer based medium combining text, audio, video, hypertext, animation, and other devices for

instruction, entertainment, or information management. Typically stored on a CD or DVD.

Example: - The World Wide Web (WWW) is the best example of hypermedia applications.

Application of Hypertext:-

1. Computer Applications.
o On line Documentation.
o User Assistance.
o S/w Engineering.
2. Business Application.
o Trade shows, Product catalogs, and Advertising.
o Dictionaries and reference books.
o Law.
3. Educational applications.
o Foreign Languages.(Includes Audio,Video)
4. Entertainment and Leisure Applications.
o Hypertext provides several opportunities for pure
enjoyment.
Example:-News, Newspapers and Magazines.

Elements of Hypertext:-

+» Nodes (A point in a network or diagram at which lines or pathways intersect
or branch.)
¢ Links(The definition of a link is a word or group of words that act as a way
to cross reference to other documents or files on the computer. A link is
defined as a ring or loop that makes up a chain.
* Annotations.

+ Buttons.


http://www.businessdictionary.com/definition/video.html
http://www.businessdictionary.com/definition/hypertext.html
http://www.businessdictionary.com/definition/device.html
http://www.businessdictionary.com/definition/information-management.html
http://www.businessdictionary.com/definition/DVD-Digital-Video-Disk.html

+ Editors.
¢ Browsers
¢ Trails
¢ Built In Programming.
Nodes:-
Hypertext is a network nodes. A node is a collection of data organized around a
specific topic and related or linked to another body of information.
Links are another fundamental unit of hypertext besides nodes. A hypertext link
has two ends.

Annotations:-

It is a special type of link, which provides specific information.
Button:-
It is visual cue in node that alerts a user that a link exists. In another words
a button is a visual representation of a link in a node.
Editors:-
It is a s/w for writing programming.
Example:-
Notepad.
Editor of C Compiler.
Editor of Basic Compiler.
Etc.
Browser:-
It is a s/w which is used for displaying effect of HTML codes (Web Page).
Example:-
Internet Explore.
Netscape navigator.
MOSAIC.



Mozila/ Fire fox.
Chimera.
Google Chrome.
Safari.
Opera etc.
Trails:-
A trail is a record of the nodes that a user accessed in viewing a hypertext
networks.

Built in programming Languaqge:-

It includes some specific feature to represent knowledge.
Example:-
Hypercard/Hypertalk.

Description of AuthoringTools:-
Multimedia authoring tools provide the important framework you need for organizing
and editing the elements of multimedia like graphics, sounds, animations and video
clips. Authoring tools are used for designing interactivity and the user interface, for
presentation your project on screen and assembling multimedia elements into a single

cohesive project.

Authoring software provides an integrated environment for binding together the content
and functions of your project. Authoring systems typically include the ability to create,
edit and import specific types of data; assemble raw data into a playback sequence or
cue sheet and provide structured method or language for responding to user input.

Introduction of CorelDRAW:-

CorelDRAW is a vector graphics editor developed and marketed by Corel Corporation
of Ottawa, Canada.

This is a popular drawing program for the Windows market. We don't support Corel
Draw specifically but can usually import its files into Macromedia FreeHand or Adobe
Illustrator if needed. Saving your drawings as an EPS (Encapsulated Postscript) file
with all the type converted to graphics is another way we can accept this format.



Question 1:-What is authoring Tools?

Question 2:-Describe different types of features of authoring s/w.?
Question 3:-What is hypertext?

Question 4:-Describe role of ImageQ, Macromedia director & Quick time.?
Question 5:-Describe about application of hypertext?

Question 6:-What are different types of hypertext elements?

Introduction of HTML (Hypertext markup Language):-

It is used for designing web page, which consist of related information that effect
display on browser. File name must be save with extension name .htm/.html.It is tag
based programming language. There are two types of tags.

<> OQOpen Tag.

</ > Closed Tag.

Format of HTML Coding:-
<HTML>
<Head>...</head>
<Title>...</title>

<Body>

</body>

</html>

Properties of Body:-
bgcolor="Color name or Color Code”.
background="1mage file with extension name .jpg or .gif”.

Text=" Color_name or Color_Code”.
Size="Values in Pixels (Picture Elements)”

Color Code & Color Name:-

Color Name Color Code
ALICEBLUE #FOF8FF




AQUA #OOFFFF
AZURE #FOFFFF
BISQUE #FFEACA4
BLUEVIOLET  #8A2BE2
CORAL #FF7F50
CYAN #OOFFFF
DEEPPINK #FF1493
DIMGRAY #696969
FORESTGREEN #228B22
GOLD #FFD700
GRAY #808080
BLACK #000000
BLUE #0000FF
BROWN #AL52A2A
CHOCOLATE #D2691E
CRIMSON #DC143C
DARKGREEN #006400
GREEN #008000
GREENYELLOW #ADFF2F
INDIGO #4B0082
KHAKI #FOE68C
LIGHTGRAY #D3D3D3
LIME #00FFOO0
LINEN #FAFOEG
MAROON #800000
IVORY #FFFFFO

Header tag:-

<h1>...</h1> The Largest Size.

<h2>...</h2>

<h3>...</h3>

<h4>...</h4>

<h5>...</h5>

<h6>...</h6> The Smallest Size.

Paragraph Taq:-
<p>.. _</p>




Center Taq:-
<Center>...</Center>
Font formatting taq:-

<b>...</b> For Bold
<i>...</1> For Italic
<u>...</u> For Underline
<Sup>...</sup> For Superscript
<Sub>...</sub> For Subscript

<Strike>...</ Strike >  For Strikeout

Font taq:

<Font>...</font>
Attribute:-
1) color=" Color_name or Color_Code”.
2) size=" Values in Pixels (Picture Elements)”
3) align=""left|right|center”
Line Taq:-
<hr>
Attribute:-
size=" Values in Pixels (Picture Elements)”
width=" Values in Pixels or %”
Color= “Color _name or Color Code”

Marguee Tag :-( It is used for moving objects).
<Marquee>...</marquee>
Attribute:-
Bgcolor=“Color name or Color Code”.
direction="left|right|up|down”
behavior="alternate or slide”
Break row Tag:-
<br>
Inline Image tag:-

<img src="1mage file with extension name .jpg or .gif or .bmp”>

Attribute:-
width="Size in pixels or %"
heidth="Size in pixels or %”




border="Values in Pixels”
vspace="Size in pixels or %”
hspace=""Size in pixels or %
align=""left|right|center”

Anchor tag:-
The anchor tag is used to create links between different objects like
HTML page files, web site (URL).

<a href=" HTML page files or URL”>Text or Graphics</a>
Example:-

ebl.html

]

eb2.html

wleb?,.html

Example of Html Code:-

<HtmI>

<Head><center><h1><u><b><font
color="red">ICSM</font></b></u></h1></center></head>
<Title>VNS</title>

<body bgcolor="green">

<p><center><h2>INDIA IS THE GREAT COUNTRY</h2></center></p>
<hr size="10" color="gold" width="90%">

<hr size="10" color="#800000" width="80%">

<hr size="10" color="#4b0082" width="70%">

<center><img src="D:\GOD\6.jpg" height="100" width="100">
<img src="D:\GOD\7.jpg" height="100" width="100">



<img src="D:\GOD\11.jpg" height="100" width="100"></center>
<hr size="10" color="#4b0082" width="70%">

<hr size="10" color="#800000" width="80%">

<hr size="10" color="gold" width="90%">

</body>

</html>
Example 2:-

<htmI>

<head><center><hl><u><b><font
color="red">ICSM</font></b></u></h1></center></head>
<title>VNS</title>

<body bgcolor="green">

<p><center><h2><marquee bgcolor="pink" direction="right"
behavior="alternate">INDIA IS THE GREAT
COUNTRY</marquee></h2></center></p>

<hr size="10" color="#4b0082" width="70%">
<center><h2><marquee bgcolor="pink" direction="left"
behavior="alternate">WELCOM</marquee></h2></center>
<hr size="10" color="#4b0082" width="70%">

</body>

</html>

bca.htm

l)cal.Ltm

T




blaz.htm

Codel:- (bca.htm)

<htmlI>

<head><center><hl1><u><b><font
color="red">WELCOME1</font></b></u></h1></center></head>
<title>VNS</title>

<body bgcolor="aliceblue">

<a href="C:\Documents and Settings\anand\My
Documents\WEB\bcal.htm"><center><h1>NEXT</h1></center></a>
<a href="C:\Documents and Settings\anand\My
Documents\WEB\bca2.htm"><center><h1>LAST</h1></center></a>
</body>

</html>

Code2:- (bcal.htm)

<htmlI>

<head><center><h1><u><p><font
color="red">WELCOME2</font></b></u></h1></center></head>
<title>VVNS</title>

<body bgcolor="silver">

<a href="C:\Documents and Settings\anand\My
Documents\WEB\bca.htm"><center><h1>BACK</h1></center></a>
<a href="C:\Documents and Settings\anand\My

Documents\WEB\bca2.htm"><center><h1>NEXT</h1></center></a>



</body>
</html>
Code3:- (bca2.htm)

<Html>

<Head><center><hl><u><p><font
color="red">WELCOME3</font></b></u></h1></center></head>
<Title>VNS</title>

<body bgcolor="green">

<a href="C:\Documents and Settings\anand\My
Documents\WEB\bcal.htm"><center><h1>BACK</h1></center></a>
<a href="C:\Documents and Settings\anand\My
Documents\WEB\bca.htm"><center><h1>FIRST</h1></center></a>
</body>

</html>

Example:-Linking with image file

<HtmI>

<Head><hl><center><font
color="red"><u>MGKVP</u></font></center></h1></head>
<Title>BHU<title>

<body background="D:\Picture 1\j.jpg">

<p><center><h2>VARANASI IS THE OLDEST CITY</h2></center></p>
<hr size="10" width="80%" color="black">

<hr size="10" width="80%" color="white">

<center><marquee direction="right" bgcolor="silver"><img src="D:\Picture 1\m1.jpg"
height="50" width="50"></marquee></center>

<hr size="10" width="80%" color="black">

<hr size="10" width="80%" color="white'>



<a href="C:\Documents and Settings\anand\My
Documents\WEB\bca.htm'><center><h1>Next</h1></center></a>

<a href="C:\Documents and Settings\anand\My
Documents\WEB\bca.htm"><center><img src="D:\Picture 1\12.gif" height="50"
width="50"></center></a>

</body>

</html>

In Line Video tag:-
It is used for playing video file.
<img dynsrc=" Video file with extension name” >
Attribute:-
Height="Values in Pixels or %”
width="Values in Pixels or %”
start="mouseover”
Loop=-1 or “infinite”
Example:-

<HtmlI>
<Head><h1><center><font
color="red"><u>MGKVP</u></font></center></h1></head>
<Title>BHU</title>
<body bgcolor="pink">
<center><img dynsrc="F:\MPEGAV1\kk.dat" height="200" width="200"
start=""mouseover'></center>
</body>
</html>
Background Sound tag:-
It is used for playing audio sound on back of the web page.

<bgsound src=" audio file with extension name” >
Attribute:-

Loop=-1 or “infinite”




Example:-

<Html>

<Head><h1><center><font
color="red"><u>MGKVP</u></font></center></h1></head>
<Title>BHU<!/title>

<body bgcolor="pink">

<bgsound src="D:\SONG\03 best of mukesh\001 MUKESH = DARD\037
PUSHPANJALI = JANE CHALE JAATE.mp3">

</body>

</html>

Multimedia Development —Issues And Suggestions

Multimedia design and development involves lot of activities.
1. Learning Interface Design
o Interface design and psychology of learning.
o Working with learning Styles.
o Considering interface design.
2. Planning the multimedia programme
o Defining the goal
o Outlining
o Logic Flow chart
o Program storyboard
o Planning for creation building blocks.

o Copyright issue and its Management.



Interface design and psycholoqgy of learning.

It associated following cycles

Pay Attention
Retrieval Rehearse
Encode
Pay Attention:- The information so gathered is transferred to the local working memory.
Rehearse:- This local memory continuously refreshed. This process is called rehearsal.
Encode:- The transfer of information to short term memory to the long term memory of the human
is called encoding.
Retrieval:- The encoded information must be retrieved from the long term memory.

Working with learning Styles:-

A lot of information of learning system should be effectively through

movement or touching. That is it includes interactive effect of sounds, video, text,

graphics etc.

Considering Interface design:-

Following fundamental rules required for multimedia design.

e

AS

Keep low cognitive load.

Do not divide the learner’s attention.

We use judicious colors, special effects and sound.
The information for learner available on screen.
Encourage frequent revision.

Encourage reinforcement of learning.

Avoid repetition of instructions.

K/ K/ K/ K/ K/ K/
L X X IR X I X R X 4




Planning the multimedia programme:-

Program
Goal

Outlines

Logic Flow
Chart

Story board
A 4
User
interface
Project
management

Program Goal:-
We will define goal of the multimedia product/System.Our objective is to develop CBT of C language.

Outlines:-
We define complete outlines of multimedia product.

Example:-
Out Line for Making CBT of C Language:-
1. Introduction of C language
1.1. Data Type
1.1.1. Integer Data Types
1.1.2. Real Data Types
1.1.3. Character Data Types
1.2. Operators
1.2.1. Relational Operator
1.2.2. Logical Operator
1.2.3. Bitwise Operator
1.2.4. Arithmetical Operator
1.3. Control
1.3.1. Decision Control
1.3.1.1.  If statement
1.3.1.2.  If-else statement
1.3.1.3.  Nested if-else statement
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1.3.1.4. Else-if construct statement
1.3.1.5.  Switch case statement

1.3.2.

Looping Control

1.3.2.1.  For loop statement
1.3.2.2.  While loop statement
1.3.2.3.  Do-while loop statement

1.3.3.

Jumping Control

1.3.3.1. Goto statement
1.3.3.2.  Continue statement
1.3.3.3.  Break statement

Array

2.1. Single Dimensional Operator
2.2. Multi Dimensional Operator

Functions

3.1. Built in Function
3.2. User defined Function

Pointer
Strings

Structure & Unions

Stacks
Queue

Linked List
10. Graphs
11. Tree

12. File Organization

Logic Flow chart:-

Main
Menu

A 4

Introduction

A 4

Basic
Concept Details

v

A 4

v

Array &
Pointer

Strings

A 4

Program storyboard:-

It is the graphical representation of the proposed multimedia project.

It includes following elements.

X3

<

X3

<

X3

*

X3

*

X3

*

Logic flow and branching sequence.
The story board template.
Animation sequence template.
Button Details template.
Audio/Video Scripting template.

User interface:-

Button, touch screen, audio, video etc facilitates interface with system.



Development Tips of Multimedia Building Blocks:-
Following important issues relating to various multimedia components.

< Text.
++ Graphics in multimedia.
+« Sound and Video in multimedia applications.

et This component of multimedia can have various types of fonts and type sizes to suit the professional
presentation of the multimedia software.
Example:-1
Times New Roman
Arial Black
Viner Hand ITC

Graphics in multimedia:-

It includes following types of graphics.

++ Background.

+«»+ Pictures, Photographs and 3 D pictures.

+« Charts, flowcharts and organization charts.
< Buttons.
Charts:-

It is graphic components.
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Digital Video:-

Digital video refers to the capturing, manipulation, and storage of moving images that can be displaced on computer
screens. This requires that the moving images be digitally handled by the computer. The word digital refers to a system
based on discontinuous events, as opposed to analog, a continuous event. Digitized video is one of the many
technologies used in the development of interactive multimedia. It offers a wide range of flexibility as compared to
standard video signal. The process of converting analog video signal to digital video signal is called sampling.

Example:-
MPEG (Moving Picture Expert Group).
AVI (Abstract Video Interface).

Sampling Process /(ﬂm‘Hmh\ /\

Analog Video Signal Digital Video Signal.
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Digital Audio:-

What is Sound:-
Vibrations that travel through the air or another medium and can be heard when they reach a
person's or animal's ear.

@ For example, a speaker in an audio system vibrates back and forth and produces a longitudinal pressure wave
that we perceive as sound.

(b) Since sound is a pressure wave, it takes on continuous values, as opposed to digitized ones.
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(c) Even though such pressure waves are longitudinal, they still have ordinary wave properties and behaviors,
such as reflection (bouncing), refraction (change of angle when entering a medium with a different density)
and diffraction (bending around an obstacle).

(d) If we wish to use a digital version of sound waves we must form digitized
representations of audio information. — Link to physical description of sound waves.

Further Description of Digital Audio:-
Digital audio is always embedded in the sound to provide additional capabilities without affecting the

CPU.A common digital sound file existing in personal computers are known as .WAV files. The MIDI
(Musical Instruments Digital Interface) sound saves disk space as it only stores the instructions about
how to play a musical instruments.It is two-way transformation

Analog «——Digital
There are following components for audio and video.
Examples:-

Sound cards



Speaker
Mike
Digital Recorder
Voice speech Synthesizer.
Winamp
Window media Player.
VLC
etc.
Signal to Noise Ratio (SNR) :-
* The ratio of the power of the correct signal and the noise is called the signal to noise ratio
(SNR) — a measure of the quality of the signal.
* The SNR is usually measured in decibels (dB), where 1 dB is a tenth of a bel. The SNR value,
in units of dB, is defined in terms of base-10 logarithms of squared voltages, as follows:
SNR =10 log10 V 2 signal V 2 noise = 20 log10 V signal V noise

Formula for determining the size of the digital audio:-

Monophonic = Sampling rate * duration of recording in seconds * (bit resolution / 8) * 1
Stereo = Sampling rate * duration of recording in seconds * (bit resolution/ 8) * 2

e The sampling rate is how often the samples are taken.

e The sample size is the amount of information stored. This is called as bit
resolution.

e The number of channels is 2 for stereo and 1 for monophonic.

e The time span of the recording is measured in seconds.

Notes:-
Multimedia Authoring:-
There are four basic function provided by almost all authoring software.
% Importing.
% Creating.
% Integrating.
¢+ Delivering.

Importing:-
It should be able to import different types of media components.
Example:-
Quick Time
Winamp
Window Media Player
VLC etc.
Creating:-

It should allow some basic features for creation of text, graphics and may be sound if not video.

Integrating:-
It allows sequence and linking of multimedia elements.

Delivering:-
It should allow developing, self-running and encryption of application data.



Clip Art
A clip art collection may contain a random assortment of images, or it may contain a
series of graphics, photographs, sound, and video related to a single topic. For
example, Corel, Micrografx, and Fractal Design bundle extensive clip art collection
with their image-editing software.
End of Multimedia

RDBMS LAB(BCA-12) MS Access
Relational database management System

What is Database:-
It is collection of well-organized related records in coherent manner. These records stored in the form of table. It
consists of rows and columns. Rows are known as tuples and columns are known as attributes.
Example: - Employee records,
Students records,
Telephone Directory,
Inventory/Stock control,
Patients records, etc.

EMP (Table):-
Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10
102 Vijay Manager 22000 20
103 Mukesh Clerk 10000 10
104 Rajan Salesman 9600 20
Eno, Ename, Job, Sal, Deptno Fields Name/Attributes Name/Column Name

Number of Attributes=5
Number of Tuples=4
Cardinality of EMP table=4
Degree/Arity of EMP=5
DBMS:-
It is an efficient system/software by which we manage database.
RDBMS:-
A relational database management system (RDBMS) is a database management system (DBMS) that is based
on the relational model/Tabular Model as invented by E. F. Codd, of IBM's San Jose Research Laboratory.
Many popular databases currently in use are based on the relational database model.

Example:-MS Access, Oracle, SQL Server, DB-2, Ingress, FoxPro etc.

Functions/Tasks of DBMS:-
% Creation of New database.
Deletion of existing database.
Renaming database.
Updating database.
Searching of records.
Sorting of records.(A To Zor ZTo A).
Indexing of records.
Creation of View (Logical table).

B Y Y G G EY



% Performing efficient query on database.
% Applying constraints (validation rules) on database.
Etc.

RDBMS:-
A relational database management system (RDBMYS) is a database management system (DBMS) that is based

on the relational model as invented by E. F. Codd, of IBM's San Jose Research Laboratory. Many popular
databases currently in use are based on the relational database model.

RDBMS stands for Relational Database Management System. RDBMS data is structured in database tables,
fields and records. Each RDBMS table consists of database table rows. Each database table row consists of
one or more database table fields.

RDBMS store the data into collection of tables, which might be related by common fields (database table
columns). RDBMS also provide relational operators to manipulate the data stored into the database tables.
Most RDBMS use SQL(Structure Query Language) as database query language.

Example:- The most popular RDBMS are MS SQL Server, DB2, Oracle and MySQL.

Three View of Data:-
1. Logical View.
2. Conceptual View.
3. Internal View.

Logical View:-
EMP (Table)
Eno
Ename
Job
Sal
Deptno
Date_Of Join
Address
Age
Conceptual View:-
EMP (Table)
Eno Number.
Ename Text.
Job Text.
Sal Currency.
Deptno Number.
Date_Of Join Date.
Address Text.
Age Number
Internal View:-
EMP (Table)
Eno Number. 12
Ename Text. 25
Job Text. 16
Sal Currency. 10
Deptno Number. 10
Date_Of Join Date. 8
Address Text. 25

Age Number 5


http://www.sql-tutorial.net/

Three Level Architecture Proposals for a DBMS:-
1. External level (Defined by User).
2. Conceptual Level (Global Level (Defined DBA).
3. Internal Level(DBA defined for optimization).

View A View B View C View D

Apflying Supplied By B BMS

Conceptual Level

\ 4

Mapping Supplied By DBMS/OS

Y

Internal Level

Types of DBMS USERS:-
1. Naive Users.
2. Online Users.
3. Applications Programmers.
4. Database Administrators(DBA).
Naive users:-
Users who need not be aware of the presence of the database system or any other system supporting
their usage are considered naive users.
Online user:-
These users may communicate with the database directly via an online terminal or indirectly via a user
interface application programs.These Users Are Aware of the Presence of Database System.
and may have acquired a certain amount of expertise in the limited interaction they are permitted with
the database through the intermediately of the application program.
Application Programmers:-
Professionals programmers who are responsible for the developing application programs or users
interfaces utilized by the naive and online users fall into this category.
DBA (Database Administrator):-
A person or group of persons under the supervision of high-level administrator experts

centralized control of the database. This person or group of person is referred to as the DBA.
Or

A database administrator (DBA) is an IT professional responsible for the installation,
configuration, upgrading, administration, monitoring, maintenance, and security of databases
in an organization.




DBA Responsibilities:-

The job of the DBA seems to be everything that everyone else either doesn't want to do, or doesn't have the
ability to do. DBAs get the enviable task of figuring out all of the things no one else can figure out. More
seriously though, here is a list of typical DBA responsibilities:-

. Installation, configuration and upgrading of Oracle server software and related products
. Evaluate Oracle features and Oracle related products
. Establish and maintain sound backup and recovery policies and procedures
. Take care of the Database design and implementation
. Implement and maintain database security (create and maintain users and roles, assign privileges)
. Perform database tuning and performance monitoring
. Perform application tuning and performance monitoring
. Setup and maintain documentation and standards
. Plan growth and changes (capacity planning).
. Work as part of a team and provide 24x7 supports when required.
. Perform general technical trouble shooting and give consultation to development teams.
Advantages of DBMS:-
1. Centralized Control.
2. Data independence allows dynamic changes and growth potential.
3. Data quality enhanced.

4. Security enforcement possible.
Disadvantages of DBMS:-

1. Problems associated with centralization.

2. Cost of Software/Hardware and migration.

3. Complexity of backup and recovery.

Concept of E-R model (Entity —Relationship) model:- Most Important
Entity:-
It is an object, which is distinguishable from other object.
Example:-
Enrollment =02181050001.

SB A/C number  =234567.
Passport Number =AB968754.
Entity Set:-
Collection of entity is called entity set.
% Employee table.
% Students Records table.
Relationship (Mapping):-
Relations between attributes of two entity sets is called mapping.
There are following types of relationships.
1. 1:1(One: One) Mapping.
2. 1. M (One: Many) Mapping.
3. M: N (Many: Many) Mapping.
Example:-
1:1(One: One) Mapping

A

bl

b2

hD
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% Relationship between enrollment number and student.
% Relationship between Passport number and person.

Employee ID | Social Security Number

A
A

Enrollment Number |, .| Student Name

4
A

1: M (One: Many) Mapping.

A B

Relationship between Manager and Employee.

Manager Employee

A
A 4

Example:-
M: N (Many: Many) Mapping




Example:-1  Relationship between suppliers and vendors
Example:-2  Relationship between Employee and Projects

Employee — » | Projects
Suppliers L % .| Vendors
Types of Entity:-

%+ Strong Entity
% Weak Entity
Strong Entity:-
An entity object which gives almost maximum related attributes information is called strong entity.

Example:-
Passport Number.
SSN (Social security Number).
UID.

Weak Entity:-
An entity object which gives minimum related attributes information is called weak entity.

Example:-
Voter Id.
Deptno.

Symbols Used In E-R Model:-

Entity Sets

Attribute/Field
/Column




Associations
/Relation

Link

Weak Entity Set

- -~o

Key Attribute

Example of E-R Model:-

Employee- Department

Job
Dname Deptno

Employee ‘ Department

Describe Concept of Abstraction, generalization, Specialization and Aggregation:-




Abstraction:-

It is simplification mechanism used to superfluous details of a set of objects; it allows
concentrating on the properties that are interest to the application.
Example:-Car is an abstraction of a personal transportation vehicle.

Generalization:-
It is the abstracting process of viewing sets of objects as a single general class. By concentrating on the
general characteristics of the constituents sets suppressing or ignoring their differences.
Specialization:-

It is the abstracting process of introducing new characteristics to an existing class of objects to create
one or more new classes of objects.

Aggregation:-
It is the process of compiling information on an object, thereby abstracting a higher-level object.

Example: - (Aggregation)

Employee

Address Deptno



Example: - (Generalization and Specilization)




Generalization

V

Full Time Employee

V

Faculty

Degree

Interest

MS Access: (Extension name .mdb)

Employee =1
S,
=
2
=
>
? \/
Part Time Employee
Staff Teaching Casuals
Classifications Stipend Hour_rate

Data Types:-
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Text

Memo(For Large Amount Of text)
Hyperlink(for Linking)

OLE(For image)

Currency(For monetary Values)
Yes/No(For Boolean values)

Autonumber(For generating automatic number)

Number
Date

Concept of Constraints (\Validation rules/Business Rule):-

It is used for validating records in table. There are following
types of constraints.

Not Null

b E

Primary key(Integrity Rulel)
Foreign Key/Reference Key(Integrity Rule2)

Unique Key
Check constraints.




6. Default constraints.
Primary key:- (Integrity Rule 1)
Column Value cannot accept null and duplicate values.
Example:-

Enrollment Number Primary key
Saving Bank A/c Number Primary Key
Passport Number Primary Key
Voter ID card Primary Key
PAN Card Number Primary Key

Etc.

Foreign Key/Reference Key: - (Integrity Rule?)
Column value referred by column of master table (Main Table).There are two

tables must be necessary.

Foreign Key/Reference Key
Primary Key

Y

\ Code?2 FName
Codel Name
101 F1
101 N1
102 F2
102 N2
103 F3
103 N3
Table T1 Table T2
Not Null:-
It can accept duplicate values but cannot accept null values.
Unique Key:-

It cannot accept duplicate but can accept null values.
Check Constraints:-
It accepts only predefined values during definition of tables.

Example: - Check (city in (“VNS”,”ALD”,”Kan”,”Luck”,”Delhi”)).
Default Constraints:-
It may accept predefined default values.

Example
Default sal (8000);



NORMALIZATION:-  (Gauranteed)
To reduce redundancy or duplicacy from database is called
Normalization technique. It is anomalous behavior of database. There are following technique to
reduce or optimize redundancy/duplicacy.
A:- 1 NF (First Normal Form).(Flat File)
B:- 2 NF (Second Normal Form)
C:- 3 NF (Third Normal Form)
D:- BCNF (Boyce codd Normal Form)
Concept of Functional dependency (FD):-
Let A and B be two attribute sets. We say that attribute B is functionally dependent on
attribute A if and only if all data items of B is dependent on Attribute set A.lt is denoted by:-

A »B

It means B is functionally dependent on A.

A » B, C.
It means B and C both functionally dependent on A.(Composite dependency)
Example:-1
Enroliment » Sname
Courese_Code » Chame
Item_Code » ltem_name
Example:-2
Order_No, Item_Code »Quantity,Price

Concept of Decomposition of Relation (Table) Scheme:-
Let R is a relation scheme which consist of Attributes A1, Az, As, As, As...An. we decompose
the relation in such manner Ri, Rz, Rs, Ra...Rp. in such a Way.

[JRi=R
i=1

Or
R1UR2UR3UR4...Rn:R
Concept of key and Non-Key:-

Key Attributes Apply primary key Constraints.
Non Key Attributes Not apply primary key Constraints
INF/Flat File: -

In first normal form, all non-key attributes totally dependent on a prime key attribute.

Example:-

Student (Erroll, Sname, Fname, Cname, Address)

Primary key



Sname

Fname

Enrollment No

Cname

Address

2NF: -
A relation is in 2 NF if it is in INF and every non Key Attribute is fully dependent on each
candidate key of the relation.All non key attributes dependent on composite key attributes.
Example:-
Order_Details (Order_no, Item_Code, Order_Date, Qty, Price_unit)
(Order_no, Item_Code) —» Composite Keys.

In Composite key dependency may not be occurring.

Order_Detall

Order_no Item _Code |Order Date Qty Price_unit
10 C1 19/11/2015 100 10
10 C2 19/11/2015 50 40
20 C1 22/11/2015 150 10
20 C2 22/11/2015 200 40
20 C3 22/11/2015 75 55
30 C1 27/11/2015 113 10
30 C3 27/11/2015 170 55

R1 (Order_no, Order_Date).
R2 (Item_Code, Price_unit).
R3 (Order_no, Item_Code, Qty).

R1UR2UR3=R(Order_Details)

Order_no

Item_Code




R1 (Table)

Order_no Order_Date
10 19/2/2012

20 22/2/2012

30 27/2/2012

R2 (Table)

Iltem_Code Price_unit

Cl 10

C2 40

C3 55

R3 (Table)

Order_no Item Code Qty
10 Cl 100
10 C2 50
20 Cl 150
20 C2 200
20 C3 75
30 Cl 113
30 C3 170
3NF:-

A relation R is in third normal form if it is in 2NF and every non key attribute of R is non

transitively dependent on each candidate key of R.

Example:-

Student (Enrol, Sname, Cname, Year,SHostel).
Student l

Primary Key

Enroll Sname Cname |Year Hostel
1234 Archana |MCA 1 Narendra_dev
2345 Vivek MCA 2 Brocha
5432 Manoj MBA 1 Narendra_dev
6789 Seema MCA 3 Birala
3421 Sandeep |BCA 3 Birala
7698 Rohan BCA 1 Narendra_dev
5689 Pravesh |MBA 2 Brocha
9006 Archana |BCA 2 Brocha

Duplicacy may occur in year and hostel.




R1 (Year, Hostel).

R1 R2 (Enroll, Sname, Chame, Year).
Year | Hostal
1 Narendra_dev
2 Brocha
3 Birala
R2
Enrol Sname Cname Year
1234 Archana MCA 1
2345 Vivek MCA 2
5432 Manoj MBA 1
6789 Seema MCA 3
3421 Sandeep BCA 3
7698 Rohan BCA 1
5689 Pravesh MBA 2
9006 Archana BCA 2

Shame

Chame

Enroll
Year
v )
Hostal

BCNFE (Boyce Codd Normal Form):-

A relation R is said to be in BCNF if X=>A holds in R, and A is not in X,then X is a
candidate key for R.In other words, a relation is in BCNF if it is in 3NF and if every determinant(left
hand side of a functional dependency) is a candidate key.

It should be noted that most relations that are in 3NF.............. are also in BCNF.Infrequently a
3NF relation is not in BCNF and this happen only if,

3 The candidate keys in the relations are composite keys (that is, they are not single attributes).
3 There is more than one candidate key in the relation.
3 The keys are not disjoint, That is, some attributes in the keys are common.



Example:-
Consider a relation scheme

Professor (Professor_Code, Dept, H_O_D, Percent_Time).

It is assumed that
1. A professor can work in more than one department.
2. The percentage of the time he spends in each department is given.
3. Each department has only one head of department.

H_ O D

Department | _—

Professor_Code ~_

"
\

Percent_Time

Department

H_OD

A 4

Department

Professor_Code

=1
\

Percent_Time




Professor_Code |Department |H O D Percent_time
Pl Physics Ghosh 50
P1 Mathematics | Krishnan 50
P2 Chemistry Rao 25
P2 Physics Ghosh 75
P3 Chemistry Rao 50
P3 Physics Gosh 40
P2 Mathematics | Krishnan 75

R1(Department, H_O_D).
R2 (Professor_Code, Department, Percent_Time).

R1

Department H OD
Physics Ghosh
Mathematics Krishnan
Chemistry Rao

R2

Professor_Code Department Percent_Time
P1 Physics 50
P1 Mathematics 50
P2 Chemistry 25
P2 Physics 75
P3 Chemistry 50
P3 Physics 40
P2 Mathematics 75

Properties of Normalized relations:-
+* No data value should be duplicated in different rows unnecessarily.
++ A value must be specified attribute in a row.
¢+ Each relation should be self-contained.
«» When arrow is added to a relation, other relations in the database should not be affected.
+» A value of an attribute in a tuple may be changed independent of other tuples in the relation
and other relations.
Different Types of Anomalies in database:-
1. Redundancy (Duplicacy).
2. Update anomalies.
3. Insertion anomalies.
4. Deletion anomalies.

Note:-
Normalization technique should be common sense.



Instances and Schema:-
Instances:-
It is collection information in the database at a particular moment is called an
instance of the database.

Database Schema:-

The overall design of the database is called the database schema.
Example:-

Table Schema (Schema for Physical table)

View Schema (Schema forLogical Table)

Index Schema (Schema for Index Table)

Differentiate between Traditional file oriented approach and Conventional or Centralized DBMS:-

Traditional File oriented approach:-
+ Data redundancy and inconsistency.
+ Difficulty in accessing data.
+ Data isolation.
%+ Atomicity problem.
Benefit of Conventional or Centralized DBMS:-
+* Redundancy can be reduced.
+* Inconsistency can be avoided.
%+ The data can be shared.
++ Standard can be enforced
¢ Integrity can be maintained (Integrity 1 and Integrity 2).
¢+ Security restriction can be applied.(User name And Password)
o It means database can access only authorized person.
o Crashes during transaction processing.
o Anomalies free database.
o Unauthorized modification of data.

Audit Trail:-
The DBMS has certain routines that maintains audit trail or journal.
It records:-
s Who
s When
s Where
s What

MS Access Objects (Extension Name .mdb):-
There are following objects available in MS access for database.
¢ Table Object.
Query Object.
Form Object.
Report.
Pages.

0:0
0:0
0:0
0:0



+» Macros
+* Module

Table Object:-
There are following three techniques for creating table object.
¢+ Creating Table Using Design View.
« By Wizard Method, (Automatic instructions provide by system).
¢ Direct Entering Method (Working Technique similar to spread sheet).

Creating Table Using Design View:-
Select Create Table Design View — Click Design Button—

A Fiedd mame can be up b B chiavacters long, nouding spaces, Fress F1 for beb on field names,

Queries:- (Questionnaires on database):- Most Important
To access records from database is called query.
There are following three techniques for performing query on database.
3 Access Design View.
3 Wizard.
3 SQL (Structure Query Language).
Operators used in query:-
% Relational operators(>,<,>=,<=,< >)
% Arithmetical Operators(+,-,*,/)
% Predicate (and, or, not, like, not like, between, not between, in, not in, any, all, not all).
Aggregate Functions Used in Query:-
sum ()
max ()
min ()
count ()
avg ()




Order Types.-
+ Ascending Order.(A-Z)—(ASC)
¢ Descending Order.(Z-A) —(DESC)

Wild cards:-

1. * For all Characters.
2. ? For any one character.
Access Design View:-

Select Query Design— Click Design Button— Add Table — Close

1. *A Display name ended with ‘A’
2. Empno in (101,102,103)

3. Empno not in (101,102,103)

4. sal between 5000 and 15000

5. Sal not between 5000 and 15000
6. Ename Like ‘A*H’

7. Ename Like’?A*L’

8. Ename Ascending

9. Ename Descending
10.Sal>=20000 and sal<=25000

SOL Method of Query:-
Select <coll>, <col2>, <col3>... from <table Name>

Where <Criteria_Expression> group by
<Aggregate_Column_name>
Order by <Column_name> asc|desc;

Example:-
Let us consider a table say EMP which is describe below

Emp (empno, ename, job, sal, deptno, address).
1:-  Todisplay all employee records.

Select * from emp;
2:- Todisplay empno, ename and job only.

Select empno, ename, job from emp;



10:-

To display employee records who is found salary more than 12000.

Select empno, ename, job, Sal from emp where sal>=12000;

To display employee records who is found salary between 7000 and 13000.
Select empno, ename, job, Sal from emp where sal between 7000 and 13000;

To display employee records whose job in clerk, steno, and salesman .

Select empno, ename, job, Sal from emp where job in (‘clerk’,’steno’,’salesman’);

To display employee records whose job not exist in clerk, steno, and salesman.

Select empno, ename, job, Sal from emp where job not in (‘clerk’,’steno’,’salesman’);
To display employee records whose name begin with ‘p’ and ended with‘a’

Select empno, ename, job, Sal from emp where ename like ‘p*a’;

To display employee records whose name begin with any character followed by ‘a’ and
remaining are any characters and ended with h.

Select empno, ename, job, Sal from emp where ename like ‘?a*h’;

To display employee records descending order by name.
Select * from emp order by ename desc;
To display employee records ascending order by name.

Select * from emp order by ename asc;

Example Based on Aggregate Function:-

1:-To display average salary, maximum salary, minimum salary, total Salary and number of
records in each department.

select avg(sal) as Average,max(sal) as Maximum,Min(Sal) as minimum, Sum(sal) as
Total_Sal,count(*) As Total_records,deptno from emp group by deptno;

2:-To display average salary, maximumum salary, minimum salary, total Salary and number
of records in department 10 and 20;



select avg(sal) as Average,max(sal) as Maximum,Min(Sal) as minimum, Sum(sal) as
Total_Sal,count(*) As Total _records,deptno from emp group by deptno having deptno in (10,
20);

Example Based on Nested Query:-

Select <coll>, <col2>, <col3>... from <table Name>

Where <col _any>=(select <col any> from <table Name> Where <col any>=(select
<col_any> from <table_Name> Where <col_any>=(select <col_any> from <table_Name>
)k

Example:-

1:-To display employee record who is found maximum salary.

Select eno, ename, job, sal, deptno from emp where sal= (select
max (sal) from emp);
2:-To display employee record who is found minimumm salary.

select eno, ename, job, sal, deptno from emp where sal=(select min (sal) from emp);

3:-To display employee record who is found Maximum or minimumm salary.

select eno, ename, job, sal, deptno from emp where sal= (select max(sal) from emp) or
sal=(select min (sal) from emp);

4:-To display employee record who is found second highest salary.

select eno, ename, job, sal, deptno from emp where sal= (select max(sal) from emp
where sal<(select max(sal) from emp));
5:-To display employee record who is found second lowest salary.

select eno, ename, job, sal, deptno from emp where sal= (select min (sal) from emp
where sal>(select min(sal) from emp));
6:-To display employee record who is found second highest or second lowest salary.



select eno, ename, job, sal, deptno from emp where sal=(select max(sal) from emp
where sal<(select max(sal) from emp)) or sal=(select min(sal) from emp where
sal>(select min(sal) from emp));

7:-To display employee records whose job is same as job of pankaj.

select eno, ename, job,sal from emp where job=(select job from emp where
ename="panka;j’);

Query Based on Joining:-
To access records more than one table we join table. There are following
categories of joining.

1. Inner join.

2. Left inner join.

3. Right inner join.

Inner Join:-
It retrieve common records from table T1 and table T2.

SELECT T1.deptl, T1.Ename, T2.dept2, T2.Ename
FROM T1 INNER JOIN T2 ON T1.deptl = T2.dept2;

Left Inner Join: -
It returns all records from left table (T1) and return from table t2 only which match from table
tl.

SELECT T1.deptl, T1.Ename, T2.dept2, T2.Ename
FROM T1 LEFT JOIN T2 ON T1.deptl = T2.dept2;

Right Inner Join: -
It return all records from right table (T2) and return only those records from table T1 that
match to table T2.

SELECT T1.deptl, T1.Ename, T2.dept2, T2.Ename
FROM T1 RIGHT JOIN T2 ON T1.deptl = T2.dept2;
Form:-
A form is a type of a database object that is primarily used to enter or display data in a
database. We can also use a form as a switchboard that opens other forms and reports in
the database, or as a custom dialog box that accepts user input and carries out an action
based on the input.

There are two ways by which we can create form.
1. Design View (Created by user).



2. Wizard technique (Automatic created with the help of instruction guideline
dialogue box).

Design View.

FORM—CLICK DESIGN—CLICK NEW—SELECT TABLE —PLACE FIELD ON
SCREEN—MAKE DESIRED BUTTON— CLICK FORM VIEW FROM VIEW

EMPLOYEE RECORD MANAGEMENT SYSTEM

a

$5,000,00

Fjziz001

n]




Wizard Technique for Making Form:-
It provide instruction dialog box and we follow according our own view.

Double Click form wizard—Select Fields from Available Field—Press Next
—Select Layout of Form—Press next — Select Form Style—Press Next
—Select Open form or Modify form and then Click Finish button.

Reports:-
It produces output on hard copy (paper) or soft copy (E -Form).

There are two technique of creating report.
3 Design View.
% Wizard View.

Reports in MS Access consist of five bands.
3 Report header.
3 Page Header.
3 Detail.
3 Page Footer.
3 Report Footer.

e Z& lq}ﬁ‘h] Z& Z'.'Zr.'; 3‘

It is similar to form but its main purpose is to navigating records.
There are two techniques for creating pages.

%o Design View.

3 Wizard View.



EMPLOYEE PAGE VIEW

| Accountank

Ernprio: ﬁ 0

Ename; | archana

Frarne: | Meerai

Sal: | $13,000.00
b_o 2 4/5/2007
Depkno: 10

EMF 1 of 2 (I S a3 - S g ]
EMP-Job 1 of & PO bk PK Hp e £ 2] S (3]

Define Export & Import features in MS Access:-

Export of MS Access Database:-

Definition of Export:-
We can export a table, query, form, report, macro, or module from one Access database to another.
When we export an object, Access creates a copy of the object in the destination database.

Select Table —Go To File menu Select Export— Select Save Type(Say MS Excel) And Type File
Name(Say EMP) —Click Export Button

Import of MS Access Database:-

Definition of Import:-

we can bring data from one Access database into another in many ways. Copying and pasting is the
simplest method, but importing and linking offer you better control and flexibility over the data that
you bring, and over how you bring that data into the destination database.

Select File—Get External data—Click Import—Chang file type And Select file name
—Press Import Button— Select Work sheet—Press next—Press next—
Press next—Press next—Select Primary key if we want to set—Press Next—Press Finish



DBMS (BCA-08)/MCA2.1/PGDCA2.1:-

What is Database:-
It is collection of well-organized related records in coherent manner. These records are stored
in the form of table. It consists of rows and columns. Rows are known as tuples and columns
are known as attributes.

Or
A database is a collection of related information stored so that it is available to users for
different purposes.The content of a database is obtained by combining data from all the
different sources in an organisation.

Example: - Employee records.
Students records.
Telephone Directory.
Inventory/Stock control.
Patients records, etc.

EMP (Table):-

Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10

102 Vijay Manager 22000 20

103 Anand Clerk 10000 10

Eno, Ename, Job, Sal, Deptno—————Fields Name/Attributes Name/Column Name

Number of Attributes=5
Number of Tuples=3
Cardinality of EMP table=3
Degree/Arity of EMP=5
DBMS:-
It is combination of H/w and S/w that can be used to set up and monitor a database.
and can manage the updating and retrieval of database that has been stored in it.
Or

It is an efficient system by which we manage database.
Example:-MS Access, Oracle, SQL Server, DB-2, Ingress, FoxPro etc.
Functions of DBMS:-

% Creation of New database.
Deletion of existing database.
Renaming database.
Updating database.
Searching of records.
Sorting of records.(A To Zor Z To A).
Indexing of records.
Creation of View (Logical table).
Performing efficient query on database.
Applying constraints (validation rules) on database.
Retrieving data collectively or selectively.
Various reports can be produced from the system.
Mathematical functions can be performed and the data stored in the database can be manipulated with
these functions.
To maintain integrity (Integrity rulel and Integrity rule2) and database use.
Etc.
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Interface User and database:-




/ DBMS o —
Base

A
A 4

C/C++/C#

Traditional File Oriented Approach:-
Following significant disadvatntage.
+» Data Redundancy/Duplicacy.
¢ Lack of Flexibility
+» Data Dependency

Motivation for Database approach:-

+»+ The work in the organization may not require significant sharing or complex Access.
¢ Powerful h/w platform s/w for database management system.

¢ Possibility of sharing of database.

¢ It must be file based.

¢+ The training of personal in the management in the use of database.

Basics of database:-

¢ Data Item.

+ Entities & Attributes.

% Logical & Physical Data.
+»* Schema & Subschema.
+ Data Dictionary.

Data Items:-

The Smallest unit of data is called data item.
Example:-

Eno=101

Ename=Ajay.

Entities & Attributes:-

Entity:-
It is an object, which is distinguishable from other object.
Example:-
Enrollment=02181050001.
SB A/c number=234567.
Passport Number=AB968754.
Entity Set:-
Collection of entity is called entity set.
% Employee table.
% Students Records table.
Attributes:-

Numbers of fields in a relation is called its attributes.



Example:-
| Eno | Ename | Job | Sal | Deptno

Logical & Physical Data:-

Logical data:-
Displaying of records by means of performing query on database is called logical data.

Physical data:-
Permanently storage of records in storage device is called physical data.

Schema & Subschema:-

Schema:-
The overall design of the database is called the database schema.
Example:-
Table Schema (Schema for Physical table)
View Schema (Schema forLogical Table)
Index Schema (Schema for Index Table)
SubSchema:-

It refers to same view but for the data-item types record types which is used in a
particular user.It is derived from schema.

Example:-
Student (Enrol, Sname, Cname, YearSHostel).  Schema Object

R1 (Year, Hostel). Sub Schema Object
R2 (Enrol, Sname, Cname, Year). Sub Schema Object
Data Dictionary:-
It holds detailed information about the different structure and data types.
It associated with different types of relationships, constraints and privileges etc.
Relationship (1:1.1:M,M:N Mapping)
Constraints (Primary key, Foreign Key, Not Null, Unique Key, Check Constraints)
Privileges (Insert, Update, Delete)

Three View of data:-
1:-Logical View.
2:-Conceptual View.
3:-Internal View.

Logical View:-

EMP (Table)

Column name




Eno

Ename

Job

Sal

Deptno

Date_Of Join

Address

Age
Conceptual View:-

EMP (Table)

Column name Data Type
Eno Number.

Ename Text.

Job Text.

Sal Currency.
Deptno Number.
Date_Of Join Date.
Address Text.
Age Number

Internal View:-
EMP (Table)

Column name Data Type Size
Eno Number. 15
Ename Text. 20
Job Text. 10
Sal Currency. 10
Deptno Number. 10
Date_Of Join Date. 8
Address Text. 25
Age Number 5



Three Level Architecture Proposals for a DBMS:-
1:-External level (Defined by User).
2:-Conceptual Level (Global Level (Defined DBA).
3:-Internal Level (DBA defined for optimization).

View A View B View C View D

A A A A

Applyjng Supplied By DBMS

A 4 A 4 A 4

Conceptual View

A

Mapping Supplied By DBMS/OS

A 4

Internal view

Types of DBMS USERS:-
1:-Naive Users.
2:-Online Users.
3:-Applications Programmers.
4:-Database Administrators (DBA).

Naive users:-
Users who need not be aware of the presence of the database system or any other system

supporting their usage are considered naive users.

Online user:-
These users may communicate with the database directly via an online terminal or indirectly via a

user interface application programs.These Users Are Aware of the Presence of Database System
and may have acquired a certain amount of expertise in the limited interaction they are permitted with the database
thought the intermediately of the application program.

Application Programmers:-

Professionals programmers who are responsible for the developing application programs or users
interfaces utilized by the naive and online users fall into this category.

DBA (Database Administrator):-
A person or group of persons under the supervision of high-level administrator experts centralized control of the

database. This person or group of person is referred to as the DBA.

Advantages of DBMS:-
1:-Centralized Control.
2:-Data independence allows dynamic changes and growth potential.
3:-Data quality enhanced.
4:-Security enforcement possible.
Disadvantages of DBMS:-
1:-Problems associated with centralization.
2:-Cost of Software/Hardware and migration.
3:-Complexity of backup and recovery.




Facilities of DBMS:-
Following types of facilities provided by DBMS
% DDL(Data Definition Language)
% DML(Data Manipulation Language)
% DCL(data Control Language)
% TCL(Transaction Control Language)

DDL:

Following commands are used in DDL.These are autocommited (Save automatically).
% Create.

DML.:-
These commands are not autocommited.
< Insert into.
< Delete.
»  Update.

L)

3

DCL:-
Such categories of commands are used for controlling data in database.
% grant (Apply privileges).
% revoke( Remove Privileges).
TCL:-
Such categories of commands are used for controlling database transaction.
% Rollback(Recall previous records)
commit( Save)

%+ savepoint (For transaction purpose)

L)

7/
o0

DBMS Structure:-

Users
Simpée users App Developers occaslonal Users DBA
Aplication routine call oonated
Programs 5 Database Schema
Precomphier of DML | afe————  Query Processor Comp@er of DOL
. Object code of
Appiication programs

Advantages of DBMS:-
1:-Centralized Control.
2:-Data independence allows dynamic changes and growth potential.
3:-Data quality enhanced.
4:-Security enforcement possible.

Disadvantages of DBMS:-
1:-Problems associated with centralization.




2:-Cost of Software/Hardware and migration.
Complexity of backup and recovery

Database Model & Its Implementation:-

FMS (File management System):-
The precursor to the present day database management system was File management System. In early data

processing of all files is called flat files. A flat file is one where each record contains same types of data
items.FMS behavior shown in following figure.

FMS Commands

HLL implementation of FMS implementation

Basic access methods

E-R Model (Entity —Relationship):-

Entity:-
It is an object, which is distinguishable from other object.
Example:-
Enroliment=02181050001.
SB A/c number=234567.
Passport Number=AB968754.
Entity Set:-

Collection of entity is called entity set.
% Employee table.
% Students Records table.

Relationship (Mapping):-
Relations between attributes of two entity sets is called mapping.

There are following types of relationships.
1:- 1:1(One: One) Mapping.




2:- 1: M (One: Many) Mapping.
3:- M: N (Many: Many) Mapping
Example:-

1:1(One: One) Mapping

% Relationship between enrollment number and student.
% Relationship between Passport number and person.

Employee ID

A
A\ 4

Social Security Number

Enrollment Number

A
A\ 4

Student Name

Example:-

1: M (One: Many) Mapping.




Relationship between Manager and Employee.

Manager Employee

A
Y
A 4

Example:-
M: N (Many: Many) Mapping

Employee Projects

A
A
Y
\ 4

Types of Entity:-
% Strong Entity
% Weak Entity
Strong Entity:-
An entity object which gives almost maximum related attributes information is called strong entity.
Example:-
Passport Number.
SSN (Social security Number).
UID(Unique Identification number)
Weak Entity:-
An entity object which gives minimum related attributes information is called weak entity.

Example:-
Voter Id.
Deptno.

Symbols Used In E-R Model:-




Entity Sets

Associations

Link

Weak Entity Set

- —

e -

Key Attribute

Example of E-R Model:-




Employee- Department

Deptno

Employee 0 Department

p e

Concept of Abstraction, Generalization, Specialization and Aggregation:-

Address

'
0

Abstraction:-

It is simplification mechanism used to superfluous details of a set of objects; it allows
concentrating on the properties that are interest to the application.

Example:-Car is an abstraction of a personal transportation vehicle.

Generalization:-
It is the abstracting process of viewing sets of objects as a single general class. By concentrating on the

general characteristics of the constituents sets suppressing or ignoring their differences.

Specialization:-
It is the abstracting process of introducing new characteristics to an existing class of objects to create
one or more new classes of objects.

Aggregation:-
It is the process of compiling information on an object, thereby abstracting a higher-level object




Example: - (Aggregation)

Employee

Address

Deptno




Example: - (Generalization and Specilization)

Employee

Generalization

uonezijelrdads

Full Time Employee Part Time Employee

hdl Y Y hdl

Faculty Staff Teaching Casuals

Degree Interest Classifications Stipend Hour _rate

Data Model Technique:-
+»» Hierarchical Data Model
+»» Network Data Model
+» Relational data Model

Hierarchical Data Model:-

A hierarchical model consist of collection records which are connected with each other
through links. Each record is collection of fields(Attributes),each of which contains one data value.
A link is an association between precisely two records.




Example:-1

Institute
A
Y
4
Programmes
A
Y
4
Courses
A
Y
\ 4
Students
Example:-2
Institute
Computer Management
Degree Diploma /\
: . Degre{: Diploma
uG PG uG PG UG PG UG P
/ \ 4 \ 4 \ 4 \ 4 \ 4 \ 4 ‘.
BCA MCA DIC PGDCA BBA MBA DIM PGDI
A A\ 4 \ 4 A\ 4 \ 4 \ 4 \ 4 VI
30 Stu 10 Stu 25 Stu 40 Stu 50 Stu 80 Stu 90 Stu 25

Network Data Model:-

The network model was formalized in the late 1960 By the database Task group of the

Conference On data System Language (DBTG/CODASYL).The first report which has been



revised a number of times, contained detailed specification for the network data model. Many
hierarchical models are associated in network model.

DBTG Set:-
It consist of following two types
** Record Types(entity type)
s Set Types. (directed relationship)

Record Types.
A record type is used to represent entity type. It is made up of a number of data items that

represent the attributes of the entity.

Set Types.
It is used to represent a directed relationship between two record types.
s Owner record Type.
+» Member record type.

) | N
M [ >
\ 4
Y N1 N2 N3
M1 M2 M3
\ 4 \ 4
P
Q R
\ 4 \ 4
P1 P2 P3 1 2 3 .
Q Q Q R1 R2 R3

w1 W2 W3

S1 S2 S3

RELATIONAL Data Model:- Most Important
This model was given by EF codd_in 1971.He also given twelve rules for complete RDBMS.
This model contains data items into tabular form.A table may consist rows and columns.
Rows are known as tuples and columns are known as attributes. Number of attributes is called
degree of relation and number of tuples is called cardinality of relation.

Advantage:-
¢ Ease of use
% Flexibility
% Security
¢+ Data Independence



% Data Definition Language.(DDL)
o Create commands
o Alter Commands
o Drop commands
¢ Data Manipulation Language.(DML)
o Insert into commands
o update Commands
o Delete commands
Data Control Language.(DCL)
o grant commands
o revoke Commands
+» Transaction Control Language.(TCL)

o%

%

o Rollback

o Commit

o Savepoint
EMP (Table):-
Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10
102 Vijay Manager 22000 20
103 Mukesh Clerk 10000 10

File organization for conventional DBMS:- MImp
Concept of File:-
It is heart of any application s/w.lIt is collection of related informations.There are
following types of files.
s Master File (Permanent Storage/Physical Storage).
» Transaction file(Logical File).
Table (It is created by DBMS. Which consist of rows and columns).
Backup(lt is for further use if files accidentally losses).
Dump File(lt is mainly used for making a copy of software for further use).
Archive File(lt is created by user when save.lIt automatically created by system for
taking backup).
File Organization:-
There are following four categories of file organizations.
¢ Sequential file Organization.
+» Relative File Organization.
+ Indexed Sequential File Organization.
« Multi Key File organization.
Sequential file Organization:-
In this file organization file records are written consecutively when the file is created and
must be accessed consecutively when the file is later used for input in a sequential file,
records are maintained in the logical sequence of their primary key values.

CAR)
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Beginning of File— 3! Racordi

Record?2
Record3
Record4
Record5
Record6
Record7
Record8

Recordh,
End of File
Index-Sequential File Organization:-
To retrieval of records by using indexed table in sequential manner. Indexed table may
consist of key value and address.lIt is suitable for large files.It improve query response.
Types of indexes:-
+«» Primary Indexes.
Clustering Indexes.
Secondary Indexes.
Multilevel Indexing Schema.
Primary Indexes:-
It is an index specified on ordering key field of an ordered file of records.It assocated with
two fields.
1:-Ordering Key field.
2:-Pointer field to a disk block.

%

>

L)

%

7
0’0
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Block1:-
Eno Ename DOB Job Sal Gender
101 Aman 5/5/1977 Clerk 12000 Male
102 Atharv 15/5/1975 Steno 20000 Male
103 Raiesh 25/4/1978 Manaaer 30000 Male
Block?2
' Eno Ename DOB Job Sal Gender
*kkk *kkk *kkk *kkk *kk*k *kk*k
*kkk *kkk *kkk *kkk
*kk*k *kk*k
*kkk *kkk *kkk *kk* *kk* *kk*k
Block3:
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*kkk *kkk *kkk *kkk *kkk *khkk




Blockn:

0120 1
31235 A 01235 3
06127 I
3TO80 C 2102 4q
Od800 3
o
08127 G
12700 7
22345 R
5T080 g

Clustering Indexes:-
If records of a file are physically ordered on a nonkey field that does not have a distinct

value for each record, that field is called the clustering field of the file.Now we will create a
different type of index,called clustering index.lIt increase speed of accessing of records.lIt is shown in

following figure.




CF Cluster Field
BP Block Pointer
Eno Ename DOB Job Sal Gender
lOl/v Aman 5/5/1977 Clerk 12000 Male
102 Atharv 15/5/1975 Steno 20000 Male
RP—\
CF BP \
1
1 ° | Eno Ename DOB Job Sal Gender
2 o—— |
3 ~o_| /
4 o\ BPﬁkJ
5 . ~
%\A Ename DOB Job Sal Gender
\\ ] ”Ih:<
Eno R Ename DOB Job Sal Gender
\ /
\\ RP'\><
Eno X Ename DOB Job Sal Gender

7

RPA/




Secondary Indexes:-
It is an orderd file with two fields and as in other indexes, The second field is a
pointer to a disk block.
+ Same data type index
¢ Non-ordering field of data file.
The field on which the secondary index is constructed is called indexing field of the file.
Now we consider a secondary index on a key field. A field having distinct value for every record in
the data file. It is sometimes called a secondary key for the file
IF Index Field Secondary Key Field
BP  Pointer

Secondary Indices Example

A-217 | Brighton 750 ~>
350 - A-101 | Downtown | 500 -J>
400 A A-110 | Downtown | 600 -<>
500 - A-215 | Mianus 700 d
600 - A-102 | Perryridge | 400 -g
700 > /—" A-201 | Perryridge | 900 ] -
750] - E /\ A-218 | Perryridge | 700 -g
Ll / " A-222 | Redwood 7001 Jd

\\" A-305 | Round Hill | 350 -%_

Secondary index on balance field of account

[l Index record points to a bucket that contains pointers to all the
actual records with that particular search-key value.

[l Secondary indices have to be dense



Multilevel Indexing:-
For full indexing scheme,the address of every record is maintained in the index.In
small file index would be small and can be processed very efficiently in main memory.
For large file the index’s size would pose problem. It create a hierarchy of indexes.

Key | Ptrnextlevel | Key Ptrnextlevel Ptrne>§|eve|
Key Ptrnextlevel
100 o
200 o—T— | Key Ptrnextlevel | Key Ptrnextlevel Ptrnextlgvel
300 o\
400 N
N
500 \®
Key Ptrnextlevel | Key Ptrnextlevel Ptrnextlgvel
Key Ptrnextlevel | Key Ptrnextlevel Ptrnextlgvel

Key Ptrnextlevel Key Ptrnextlevel Ptrnextlgvel

A 4




Multi-Level Index
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Componenents of Index Sequential

% A primary data storage area
% Overflow area

¢+ A hierarchy of indices

Important technigue of Building Index:-

s ISAM(Index Sequential Access Method)
s VSAM(Virtual Storage Access Method)

ISAM:-

When record is stored by ISAM ,its record key must be one of the fields in the record.ISAM
will always maintains the records in the sorted order Each record stored on one the tracks of disks.
It is shown in following figure:-
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ISAM file is spread over several cylinders; There is more than one track index.
The cylinder index is not associated with any particular cylinder of the file and is stored in a
separate area or on another disk together.

Overflow records in ISAM:-
- - - 21 22 23 24 25

Next record is added in next track

- - - 30 29 28 27 26




Algorithm:-

Step 1:-Find the first available position in the overflow area.

Step 2:-Move the record to this position

Step 3:-If this record is the record of the lowest key in the overflow area, place the pointer to this
Record in the overflow entry of the track index and move the old value in the track index.

Advantage:-
¢ It is good for static tables.
» There are fewer disk 1/0O required to access data, provided there is no overflow.

0

*

L)
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Disadvantage:-
+ It is not quick as compare to hash organization.
+»+ Overflow can be a real problem in highly volatile tables.
N=N+1

VSAM (Virtual Storage Access Method):-
Index and data are assigned to distinct blocks of virtual storage. Which is called control
interval.File are made up two components
% Index
s Data
Accessing of data performed through index in sequential manner

Direct File Organization:-

¢+ This method of accessing records performed by hash function. which accept key value and
provide address of corresponding key.

key value Hash function

h(k) > Address

v

Hashing function work as below
h(k)=k mod s
s=Super bucket address value-lower bucket addresss value+1
k is the numeric key value
Advantage:-
+» Exact key matches are extremely quick.
¢ Itis very good for long key.
+ No disk space is used by this indexing method
Disadvantage:-
a:-Itis very difficult to predict overflow.
b:-No sorting of data occurs either physically or logically



Multikey File Organization:-
There are numerous techniques that have been used to implement multikey file
organization.
Example:-
In banking system there are several types of users
Such As ATM users, Loan Officers, Branch Managers, Bank Officiers, Account holders
and so forth.There are two approaches for providing additional access paths into a file of
data records

= Multi List File Organization
= |nverted File Organization
Multi List File Organization:-
In multilist file organization, record disk blocks are linked by means of pointer in
sequential manner.

Rec Ptrnextlevel .| Rec Ptrnextlevel > Rec Ptrnextlevel
Key Ptrnextlevel
100 e
200 o—T—— | Rec Ptrnextlevel | Rec Ptrnextlevel ——i‘» Rec | Ptrnextlevel
300 o\
400 N
N
500 \®
Rec Ptrnextlevel .| Rec Ptrnextlevel
— L
Rec Ptrnextlevel o.. || Rec Ptrnextlevel
I
—» Rec | Ptrnextlevel
Rec Ptrnextlevel | Rec Ptrnextlevel
—» Rec| Ptrnextlevel
Coral rings:-

The coral rings structure is an adaptation of the doubly linked multi list structure.

Rec Ptrnextlevel Rec Ptrnextleve2 Rec Ptrnextleve3

v
A 4

PtrPrevlevel <
Rec Rec PtrPrevieve?2 |« Rec PtrPrevleve3




Inverted File Organization:-

Conceptually inverted files are similar to multilists. The difference is that while in
multilist records with the same key value are linked together with the link information being kept in
individual records.

In case of inverted files, this link information is kept in index itself.

Emp Index
100 Occupation Index Gender Index
200 President A Male A B, C
300 Programmer B,CD
Female D,EF
400 Analyst E,F
City Index Salary Index
ALD AB 25000 A
LUCK C,D 18000 B,C D
VNS F 16000 F

Evaluation of DBMS:-
Following technical criteria could be the following for evaluation of DBMS.
SQL implementation
Transaction Management
Programming Interface
Database server environment
Data storage feature
Connectivity
. DBMS integrity(Integrity-1,Integrity-2)
Administrative criteria for DBMS:-
1. Required H/w platform
2. Documentation
3. Vendor Support
4. Initial Cost
5. Recurring Cost
Data Storage Features:-
It is categorized into following three parts.
a. Lost database segment
b. clustered indexes

NoakowdE




c. clustered tables

Rating Function:-

1. Linear.

2. Broken linear.

3. Binary.

4. inverse.
Analyst Could Use a Five Point Scale with Linear Rating Functions.
Feature evaluation Rating point
Excellent(A) 5
Good(B) 4
Average(C) 3
Fair (D) 2
Poor (E) 1

Linear:- Rating increases in proportion to higher marks.

A

v

12345678910

Broken Linear:- There are situations where the min threshold is essential and similarity there is saturated value
above which no additional value is given

v

3456789
Binary Linear:- A system either does or does not have the feature or some minimum




v

Inverse :- Higher mark produce lower rating

A

v

Concept of Relation:-
Let A and B be any two sets.Its Cartesian product defined as

A*B  ={(a,b) | a is the element of set A and b is the element of set B}
Example:-
A= {5,6}
B={8,9}
A*B={(5,8),(5,9),(6,8),(6,9)}
5R8=(5,8)
5R9=(5,9)
6R8=(6,8)
6R9=(6,9)
Codd Rules for RDBMS:-
Mr E.F. codd given twelve rules for RDBMS in 1971.These rules are
described below
1. The information Rule
All information is explicitly and logically represented in exactly one way.
2. The rule of guaranteed access




Every item of data must be logically addressable by resorting to a
combination of table name, primary key value and column name.
3. The systematic treatment of null values

Example:-
Field Name Empno Ename Job Sal
Data Type Number Char Char Currency
101 Ajay Steno 12000
102 # # # Systematic Treatment
103 # # 0 Not Systematic treatment

4. Database description rule

After creating database, It must be describe by defined available commands.

Example:-
Suppose we create a table say EMP (Empno, Ename, Job, Sal, Deptno)
SQL>Desc EMP=>Describe rule
5. The comprehensive sub language rule
It must support for following rules with respect to commands.
DDL (Data Definition Language)
DML (Data Manipulation Language)

DCL (Data Control Language)
TCL(Transaction Control Language)

7/ 7/ 7/
LXK X g

7/
X4

L)

DDL.:-
Following commands are used in DDL.These are autocmmited.
% Create.
s Alter.

% Drop.

L)

DM

r

These commands are not autocommited.
% Insert into

L)

% Delete
% Update
DCL:-
Such categories of commands are used for controlling data in database.
% grant To provide privileges
% revoke To remove privileges
TCL:-

Such categories of commands are used for controlling database transaction.
% Rollback To recall records
s Commit To Save Records
% Savepoint  For transaction purpose only

6. The View updating Rule:-

All views that can be updated in theory,can also be updated by the system.

Note:-view is an logical object, which mapped through master table/Main Table/Physical
database.

Example:-

EMP (Empno, Ename, Job, Sal, Deptno, Contact _Number, Address,SBA/c_No) Master table

Create View object say (Viewl)



Viewl (Empno, ename, job, sal) Transaction table/Client User
Client user may perform addition, deletion, updation, modifications of records in master table.

7 . The Insert and Update Rule:-
An RDBMS must be facilitating to insert and update any information into database.

8 .The Physical independence rule:-

User access data from database through program via terminal.
=
Server (Physical database) Client User

Logical Database

0OS DBMS

A
A 4
A

9 .Logical & Data independence rule:-
Application programs must be independent of changes made to the base
tables/Master Table/Main Table.
10 .Integrity rule:- Most Important
There are two types of integrity rules.
¢ Integrity Rulel/Primary Key Attribute.

Primary key:- (Integrity Rule 1)
Column Value cannot accept null and duplicate values.

Example:-
Enrollment Number Primary key
Saving Bank A/c Number Primary Key
Etc.

+» Integrity Rule2/Referential Integrity

Foreign Key/Reference Key: - (Integrity Rule2)
Column value referred by column of master table (Main Table).There are two tables must

be necessary.

Foreign Key/Reference Key
Primary Key

Cdgel Name Code2/ FName
101}( N1 1 / F1

\

102 N2 102 F2

103 N3 103 F3



11 .Distribution rule:-
A RDBMS must have distribution independence.

y
DBMS
Server @

12 .No subversion rule:-
Under this method, any user can not be able to bypass any integrity rules or constraints of the
relational language.

»
»

<

Relational Algebra:-
It is a procedural language. It specifies the operations to be performed on

existing relations to derive result relations. There are following types of basic operations.

s Difference (-)

¢ Intersections (N)

+» Cartesian Product( x)

¢ Projection(IT)

¢ Selections(o)
+«» Division &)
% Natural Join (X)

)

Difference (- ) :-
Let Pand Q are two relations

It is defined as



P
ID Name
101 Amit
103 Ajay
104 Sanjay
107 Neeraj
110 Madan

Intersections (N):-
Let P and Q are two relations.
It is defined as

PNQ
ID Name
103 Ajay
104 Sanjay
110 Madan

Cartesian Product (x):-

R=P-Q= {t| t belong in relation P and t does not belong in relation Q}

P-Q Q-P
ID Name ID Name
101 Amit 106 Mohan
107 Neeraj

Q
ID Name
103 Ajay
104 Sanjay
106 Mohan
110 Madan

R=PNQ= {t|t belong in relation P and t belong in relation Q}

Let P and Q are two relations.
It is defined as
R=PxQ=P||Q={t1 || t2 |t1 belong in relation P and t2 belong in relation Q}

The relation Scheme of P and Q is represented as

A= {3,5}
B={4,7}

A*B={(3.4),(3.7),(5,4).(5.7)}

3R4:(3,4)
3R7:(3,7)
5R4:(5,4)
5R7=(5,7)

B*A={(4.3).(4.5).(7.3).(7,5)}

4R3=(4,3)
4R5=(4,5)
7R3=(7,3)
7R5=(7,5)

R=P|Q

Degree/Arity of R is calculated as

IRI=[P[+|Q]

Cardinality of R is calculated as

IRI=IP[*QI

Example Based On relation:-




P(Employee table) Q(Project)

ID Name P_Name
101 Amit s1
103 Ajay

104 Sanjay 52
107 Neeraj

110 Madan

PIQ

ID Name P Name

101 Amit S1

101 Amit S2

103 Ajay S1

103 Aijay S2

104 Sanjay | S1

104 Sanjay | S2

107 Neeraj S1

107 Neeraj S2

110 Madan | S1

110 Madan | S2

Projection (M):-
The projection of a relation is defined as a projection of all its tuples over some set of attributes.

Example:-
P(Employee table) Miq P(Employee table)

ID Name ID

101 Amit 101
103 Ajay | 103
104 Sanjay 104
107 Neeraj 107
110 Madan 110

P(Employee table) Mname P(Employee table)



ID Name Name

101 Amit Amit

103 Ajay > AJay

104 Sanjay Sanjay

107 Neeraj Neeraj

110 Madan Madan
EMP
Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10
102 Vijay Manager 22000 20
103 Mukesh Clerk 10000 10

I-IEno, Ename, Job EMP

Eno Ename Job

101 Ajay Steno

102 Vijay Manager

103 Mukesh Clerk

Selections(o) : -

It is an operation that selects only some of the tuples the relations.Such operations is known as a

selection operations.

Example:-
EMP
Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10
102 Vijay Manager 22000 20
103 Mukesh Clerk 10000 10
104 Sneha Steno 13000 20
105 Afroj Accountant 15000 30
EMP1=6gno<-10s EMP
Eno Ename Job Sal Deptno
101 Ajay Steno 12000 10
102 Vijay Manager 22000 20
103 Mukesh Clerk 10000 10
EM P2:Gjob:”3teno” EMP
| Eno | Ename | Job | Sal | Deptno




101

Ajay

Steno

12000

10

104

Sneha

Steno

13000

20

EMP3= Ggno<=102 (I'Ieno, Ename, Job) EMP

Eno Ename Job
101 Ajay Steno
102 Vijay Manager

EMP4= neno, ename (OEno<=102 (I‘Ieno, Ename, Job) EMP)

Eno Ename

101 Ajay

102 Vijay

Division):-

Example:-

P Q P:Q
A B B A
al bl bl al
al b2 b2 a5
a2 bl
a3 bl
ad b2
ab bl
ab b2

Q
A Q=P
al
a2 B
a3 bl

Natural Join (I )

EMP1

Eno Ename Job

101 Ajay Steno

102 Vijay Manager

EMP2

Eno Ename Sal

101 Ajay 12000

102 Vijay 13000

EMP1X EMP2

| Eno | Ename | Job | Sal




101 Ajay Steno 12000

102 Vijay Manager 13000

Normalization:- ( Most Important)

Anomalies Behavior of relation:-
Anomalies in database is an abnormal behavior of relation, It should not found in relation, If It
occurs in database we must be remove or minimize from database by using normalization technique.
OR
Normalization is a process of organizing the data in database to avoid data redundancy, insertion
anomaly, update anomaly & deletion anomaly.
Different Types of Anomalies in database:-

* Redundancy (Duplicacy).
¢ Update anomalies.

¢ Insertion anomalies.

¢ Deletion anomalies.

Concept of Constraints (\VValidation rules/Business Rule):-
¢ Primary key(Integrity Rulel)
Foreign Key/Reference Key(Integrity Rule2)
Not Null.
Unique Key.
Check constraints.
Default constraints.
Primary key:- (Integrity Rule 1)
Column Value cannot accept null and duplicate values.

R/
0‘0 D)

3

%

3

*

R/
0’0

3

A

Example - Primary Key
Ero Ename Job
101 Ajay Steno
102 Vijay Manager
Enrollment Number Primary key
Saving Bank A/c Number Primary Key
Passport Number Primary Key
Voter ID card Primary Key
PAN Card Number Primary Key

Etc.



Foreign Key/Reference Key: - (Integrity Rule2)
Column value referred by column of master table (Main Table).There are two tables must be
necessary.

Primary Key )
Foreign Key/Reference Key
A
3
17 CeﬁeZ FName
Codel Name
101 F1
101 N1
102 F2
102 N2
103 F3
103 N3
Table T1 Table T2
Not Null:-

It can accept duplicate values but cannot accept null values.

Unique Key:-

It cannot accept duplicate but can accept null values.
Check Constraints:-
It accepts only predefined values during definition of tables.

Example: - Check (city in (“VNS”,”ALD”,”Kan”,”Luck”,”Delhi”)).
Default Constraints:-
It may accept predefined default values.

Example
Default sal (8000);

Concept of Functional dependency (FD):-




In relational database theory, a functional dependency is a constraint between two sets of attributes
in a relation from a database. In other words, functional dependency is a constraint that describes the
relationship between attributes in a relation.
OR
Let A and B be two attribute sets. We say that attribute B is functionally dependent on attribute A if
and only if all tuples of B is dependent on Attribute set A.It is denoted by:-
A -B

It means B is functionally dependent on A.

A » B, C.

It means B and C both functionally dependent on A.(Composite dependency)

Example:-1
Enrollment » Sname
Courese_Code » Chame.
Item_Code »Item_name.
Example:-2
Order_No, Item_Code » Quantity,Price.

Concept of Decomposition of Relation (Table) Scheme:-
Let R is a relation scheme which consist of
Attributes A, Az, Az, A4, As...An. We decompose the relation in such manner Ry, Rz, Rs,
Rs...Rn.
Way.

Or
R;UR,UR3UR,...R=R

Example:-1

Order_Details (Order_no, Item_Code, Order_Date, Qty, Price_unit)
R1 (Order_no, Order_Date).
R2 (Iltem_Code, Price_unit).
R3 (Order_no, Item_Code, Qty).
R1UR2UR3= Order_Details

Concept of key and Non-Key:-

Key Attributes Apply Constraints.
Non Key Attributes No Any Constraints
INF/Flat File: -

In first normal form, all non-key attributes totally dependent on a prime key attribute.

Example:-



Student (Etroll, Sname, Fname, Cname, Address)

Primary Key
Sname
Fname
Enrollment No

Cname

Address
Primary Key
Enrollment Sname Fname Cname Address
101 Mayank Ajay BCA Lanka Vns
102 Priyanka Vijay MCA Sigara Vns
103 Amazad Asalam BCA Akhari VNS
2NF: -

Arelation is in 2 NF if it is in INF and every non Key Attribute is fully dependent on each

candidate key of the relation.All non key attributes dependent on composite key attributes.
Example:-

Order_Details (Order_no, Item_Code, Order_Date, Qty, Price_unit)

(Order_no, Item_Code) —> Composite Keys.

In Composite, key dependency may not be occur.

Order_no Item_Code Order_Date Qty Price_unit
10 C1l 19/2/2012 100 10
10 C2 19/2/2012 50 40
20 C1l 22/2/2012 150 10
20 C2 22/2/2012 200 40
20 C3 22/2/2012 75 55
30 C1l 2712/2012 113 10
30 C3 27/2/2012 170 55

R1 (Order_no, Order_Date).
R2 (Item_Code, Price_unit).



R3 (Order_no, Item_Code, Qty).

R1UR2UR3= Order_Details

Order_no

R1 (Table) Order No——>Order_date

Order_no Order_Date
10 19/2/2012

20 22/2/2012

30 27/2/2012

R2 (Table) Item Code———Price Unit
Item_Code Price_unit

cl 10

c2 40

c3 55

R3 (Table) Order No,ltem Code ———Qty
Order_no Item_Code Qty
10 cl 100
10 c2 50
20 cl 150
20 c2 200
20 c3 75
30 cl 113
30 c3 170
3NFE:-

A relation R is in third normal form if it is in INF and every non key attribute of R is non
transitively dependent on each candidate key of R.

Example:-
Student (Enrr)l, Sname, Cname, Year<= Hostal).



Primary Key

Enrol

Sname

Chame

Year

v 4

Hostel




Student:-

Enrol Sname Cname Year Hostel
1234 Ajay MCA 1 Narendra_dev
2345 Vivek MCA 2 Brocha
5432 Manoj MBA 1 Narendra_dev
6789 Seema MCA 3 Birala
3421 Sandeep BCA 3 Birala
7698 Rohan BCA 1 Narendra_dev
5689 Pravesh MBA 2 Brocha
9006 Archana BCA 2 Brocha
Duplicacy occur in year and hostel.
R1 (Year, Hostel).
R1 R2 (Enrol, Sname, Cname, Year).
Year Hostel
1 Narendra_dev
2 Brocha
3 Birala
R2
Enrol Sname Chame Year
1234 Ajay MCA 1
2345 Vivek MCA 2
5432 Manoj MBA 1
6789 Seema MCA 3
3421 Sandeep BCA 3
7698 Rohan BCA 1
5689 Pravesh MBA 2
9006 Archana BCA 2




BCNF (Boyce Codd Normal Form):-

A relation R is said to be in BCNF if X=> A holds in R, and A is not in X then X is a
candidate key for R.In other words, a relation is in BCNF if it is in 3NF and if every determinant(left
hand side of a functional dependency) is a candidate key.

It should be noted that most relations that are in 3nf are also in BCNF.Infrequently a 3NF relation is
not in BCNF and this happen only if,

3 The candidate keys in the relations are composite keys (that is, they are not single attributes).
3 There is more than one candidate key in the relation.
3 The keys are not disjoint, That is, some attributes in the keys are common.
Example:-
Consider a relation scheme
Professor (Professor_Code, Dept, H O_D, Percent_Time).
It is assumed that:-
A professor can work in more than one department.
+»+ The percentage of the time he spends in each department is given.

R/

+ Each department has only one head of department.

H OD

Department -

Professor_Code [~

"
\

Percent_Time

Department » HOD
/ Department

H_ O D T

Professor_Code \

Percent_Time




Professor_Code | Department |H_ O D Percent_time
Pl Physics Ghosh 50
P1 Mathematics | Krishnan 50
P2 Chemistry Rao 25
P2 Physics Ghosh 75
P3 Chemistry Rao 50
P3 Physics Gosh 40
P2 Mathematics | Krishnan 75
R1 (Department, H_O_D).
R2 (Professor_Code, Department, Percent_Time).
R1
Department HOD
Physics Ghosh
Mathematics Krishnan
Chemistry Rao
R2
Professor Code Department Percent Time
P1 Physics 50
P1 Mathematics 50
P2 Chemistry 25
P2 Physics 75
P3 Chemistry 50
P3 Physics 40
P2 Mathematics 75

Distributed databases:-

In a distributed database system, the database is stored on several computers.
The computers in a distributed system communicate with each other through various
communication media, such as high speed buses or telephone lines or satellite or terrestrial system.
They do not share main memory, nor do they share a clock. The processor in a distributed system
may vary in size and function.It includes microcomputer, Work Stations, Mincomputer and large

general purpose computers.
Features/Advantages:-

D)

+« Availability.
» Reliability.

>

D)

(AR

D)

(AR

Disadvantages:-

» Speed up query processing.
+» Data sharing and distributed control.

% Software development cost.
¢ Greater potential for bugs.
¢ Increased processing overhead.

Important




Network Topology for Distributed Database:-
Topology:-It is physical layout of computer network.
¢ Fully connected network
Partially connected network
Tree structure network
Star network
Ring Network

J/
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Partially connected network:-
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STAR network:-
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RING network:-
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DESIGN OF DISTRIBUTED DATABASES:-
There are several issues that are specific to distributed databases.
¢ Replication
+ Fragmentation
¢ Replication & Fragmentation
Replication:-
The system maintain several copies of the relations (Table).Each replica is stored in a
different site.Replication is to store only one copy of relation.
Advantage of Replication:-
+ Availability.
¢ Increase parallelism.
¢ Increase overhead on update.
Fragmentation:-
The relation is partitioned into several fragments. Each fragment stored in a different site.




Replication & Fragmentation:-
It is combination of the above both two technique.
Fragmentation:-
Let r is relation divided into a number of fragments r1, r2, r3, r4...ry.It is divided into two parts.
¢ Horizontal Fragmentation (o)
¢ Vertical fragmentation ()

Vertical Fragmentation (IT)

n
uri =T

EMP(R)

Enrollment Sname Fname Cname Address

101 Mayank Ajay BCA Lanka Vns
102 Priyanka Vijay MCA Sigara Vns
103 Amazad Asalam BCA Akhari VNS

R1=11 Enrollment, Fname, Address EM P(R)

Enroliment Fname Address

101 Ajay Lanka \Vns
102 Vijay Sigara Vns
103 Asalam Akhari VNS

R2 :H Enrollment, Sname, Cname EM P(R)

Enroliment Sname Cname
101 Mayank BCA
102 Priyanka MCA
103 Amazad BCA

QRi:R

Horizontal fragmentation (o):-

i=ori(r)

r=riXr2X r3Xr4...rn



EMP

Enrollment Snhame Fname Cname Address

101 Mayank Ajay BCA Lanka Vns
102 Priyanka Vijay MCA Sigara Vns
103 Amazad Asalam BCA Akhari VNS
104 Rahamat Ashalam MCA Kandawa VNS
Rl=o Cname=’BCA’( EM P)

R2=o¢ Cname=’MCA’( EM P)

Rl=o Cname=’BCA’( EM P)

Enrollment Sname Fname Cname Address

101 Mayank Ajay BCA Lanka Vns
103 Amazad Asalam BCA Akhari VNS
R2=o¢ Cname=’MCA’( EM P)

Enrollment Sname Fname Cname Address

102 Priyanka Vijay MCA Sigara Vns
104 Rahamat Ashalam MCA Kandawa VNS
EMP=R1IXR2

OODBD:-Object Oriented Database design:-

Object oriented database design which must be support following three properties.
+« Polymorphism(P)
¢ Inheritence(l)
+«» Encapsulation(E)
Polymorphism:-
A single function may perform various types of tasks depending upon arguments.

Example:-

draw (line)

draw (Circle) O

draw (Rectangle)

draw(oval)

Inheritence:-

It means reusability. That is property of base class(Father Class) is going to access by its derive
class(Children Class).Whose property is going access is called as base class(Father Class) and in
which the property is access is called as a derive class(Children Class).

Base Class

\ 4
Derive Class




Encapsulation:-
It is an abstraction process of binding and hiding properties.
Concepts of Class & Objects:-

Class:-
It is combination of data member (Attributes) and member functions (Behaviors).lIt has no physical
existence.

Example:-
Class person

Class Animal
Class Vehicle
Class Vegatable
Class Students
Class Teachers
Class Leader
Class Country
Class Temple
Class Furniture
Etc.
Object:-
It is an instance of class is called object.
Example:-
Ravi is an object of class person.
Monkey is an object of class animal.
Format of class Declaration:-
class <class_Name>
L
Private :
Data_members;
Member_functions;
public:
Data_members;
Member_functions;
protected:
Data_members;
Member_functions;

Y
Where :-
Private, public and protected are called visibility mode.

Feature of OODBDs:-

% Reusability.
Polymorphism.
Encapsulation.
Generacity.

Data abstraction.
Distributed database perform.
Robust.

High security.
Portable.

High performance.

X/ X/
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Introduction of SOL :-

Data types:-

char(size)
varchar(size)
varchar2(size)
number (m,n)

It can hold 255 characters.

It can hold 2000 characters.

It can hold 2000 & More characters
m, Size of numbers before decimal.

Field size fixed.
Field size may be variable.
Field size may be variable.

n ,Size of numbers after decimal.

date dd-mm-yy Size 8 characters

long It is used to store variable length character
strings containing upto 2 GB

raw/long raw

Creation of user account in Oracle:-

Types of Uesr and password:-
Username/Password
¢ Internal/oracle
s System/Manager
¢ Scott/Tiger

Ordinary User.

How to connect and start database:-

Stepl:- Open Svrmgr Prompt (svrmgr>)

The Strongest user.
Less power than Internal.

O O O O O O O O

It is used to store binary data such as
digitized picture or image.

For startup/Shutdown Database
For creating user accounts and database.
For working purpose like
Creation table

Deletion table

Query performing

Sorting

Indexing

Sequencing

Updation

Programming etc.

Step2:- Type connect/Internal and press Enter Button.
Step3:- Type Startup and Press Enter Button.

How to close database:-

Stepl:- Type Shutdown and Press Enter Button.

How to connect (System/ manager):-

SQL>create user <user_Name> identified by <password>+'

SQL>grant connect, resource to <user Name>:

How to connect User:-
SQL>Connect <user_name>/Password; +
How to Delete User Account:-
SQL>Connect System/manager; +'




SQL>Drop user <user name>:+
Log On

User Name: |system

Password: |

Host String: |

How to connect Scott Tiger:-
SQL>Connect Scott/Tiger; «

How to Exit From User:-

SQL>Exit; +

Example For creation user account
SQL>create user icsm identified by uprtou; +
SQL>grant connect, resource to icsm; «
SQL> Connect icsm/uprtou; +

Example For Removing user account
SQL>Drop user icsm; «

Syntax For creation of Table:-

SQL>Create table <table_name>(COL1 <datatypel>(sizel) [Constraints], COL2 <datatype2>(size2) [Constraints],
COL3 <datatype3> (size3) [Constraints]...);

Example For creation Table:-
SQL>Create table emp(Empno number(10) primary key,Ename varchar2(15) not null,Job char(10),sal number(9,2),

deptno number(10)); +*

Syntax for Insert Record Into Table:-
SQL>Insert into <table_Name>[(COL1,Col2...)] values(&Arg_COL1, (&Arg_COL2,...);+

Example For Insert Record Into Table:-

SQL>Insert into emp values (&eno, ‘&name’, ‘&Job’, &sal, &Dept); +
Example For Insert Record Into Specific Column:-
SQL>Insert into EMP (Empno, Ename) values (&eno, ‘&name’); <
Example For Displaying whole records:-

SQL>Select * from emp; <

Example For Describing Table Structure:-

SQL>desc emp; «

Example For Describing specific fields from Table :-
SQL>Select empno, ename, job, sal from emp; <

Example For Describing specific fields from Table using Criteria :-
SQL>Select empno, ename, job, sal from emp where sal>=10000; «'

How to Apply Validation/Constrant Rules on Attributes:-
Apply Of Primary key:-

<Name_of Column> Primary Key



Example:- Empno number(12) primary key

How to Make Commposite key:-

Primary Key (<Name_of Columnl1>, <Name_of Column2>...)

Example:- primary key(eno,ssn)
eno  ssn
101 001 \Valid
101 001 Not Valid
101 002 Valid
102 002 Valid
101 002 Not Valid

How to Make Reference Key:-

<data_Type> <column_name2> references <Master_Table>(<column_namel>);
Example:-
T1(codel, Ename)— —codel Primary Key:-

SQL>create table T1(codel number(10) primary key,Ename varchar2(15));
T2(code2,Fname) — —Code2 Reference key:-

SQL>create table T2(code2 number(10) references T1(codel),Fname varchar2(15));
Example of Making Composite Key:-

SQL>create table t2(codel number(10),ssn number(12),ename varchar(15),fname

char(18),primary key(codel,ssn));

How to Make Unique Key:-

...<Name_of Columnl> unique,...
SQL>create table t3(eno number(10) primary key,ename varchar(15),UID number(10)
unique,fname varchar(15));
How to Make Not Null Key:-
...<Name_of Columnl1> not null,...
SQL>create table t3(eno number (10) primary key,ename varchar(15) not null,UID
number(10) unique,fname varchar(15));
How to Make Chegue Constraints Key:-

...cheque(<column_name> in (<Criteria_expression>))...

SQL>create table t1(eno number(10) primary key,ename varchar(15) not null,city
varchar(15) check (city in(‘ald','kan’,'luck’,'vns")),job varchar(15));

How to Make default Key:-

...default <column name> (value)...

SQL>create table t1(eno number(10) primary key,ename varchar(15) not null,city



varchar(15) check (city in(‘ald','’kan")),job varchar(15),sal number(10)
default(7000)); <

Alter Command:-
This command is used for editing column value, adding new column, removing
existing column in a table object.

a:- Alter Table <table_Name> add(<new_col1> <data_type>(sizel),
<new_col2> <data type>(size2), <new col3> <data type>(size3),...)

b:- Alter Table <table_Name> drop column <column_name>;

c:- Alter Table <table_Name> modify(<new_coll> <data type>(mod_sizel),
<new_col2> <data_ type>(mod_size2),...)

Example of a:-

SQL>alter table t1 add(sal number(10));

Example of b:-

SQL> alter table t1 drop column job;

Example of c:-

SQL>alter table t1 modify (eno number (14));

Update command:-
This command is used for updating data values, insert value after adding new
column.
update <table name> set=<Columne Valuel>,<Columne Value2>...
where <criteria_On_Column>;

Example :-
update t1 set sal=&sal where eno=&no;

Delete command:-
This command is used for deleting record.

delete from <table_Name> where <criteria_Column>;

SQL>delete from emp;

SQL>delete from emp where empno>=110;

SQL>delete from emp where job="Steno” OR job="Clerk”;
SQL>delete from emp where empno=&no;



Creation of table Using Existing table:-

Create table <table Name> as select <coll1>,<col2>,... from <table name> where
<criteria_expression>;

Example:-
create table empl as select empno, ename,job from emp where empno>=105;

Commit/Save-
It is used for saving records.
Example:-
SQL>commit;
Rollback-
It is used for recall previous records after performing DML transactions.
SQL>Rollback;

Savepoint-
It is working area for performing transaction purpose.

Savepoint a

Savepoint b
Savepoint ¢

SQL>Rollback to savepoint a; (it means rollback all a, b and c)
SQL>Rollback to savepoint b;(it means rollback both b and c)
SQL>Rollback to savepoint c; (it means rollback only c)

Syntax for creation of savepoint Area:-

SQL>savepoint a;

SQL>savepoint b;

SQL>savepoint c;
Example:-

SQL>rollback to savepoint c;

SQL>rollback to savepoint a;

Performing Query On EMP:-

EMP (Empno, ename, job, Sal, Deptno, mgr, comm, hiredate)

Syntax:-

Select <coll>, <col2>, <col3>... from <table Name>
Where <Criteria_Expression> group by
<Aggregate_Column_name>

Order by <Column_name> asc|desc;



Operators used in Sqgl query:-
3 Relational operators(>,<,>=,<=,<>)
3 Arithmetical Operators(+,-,*,/)
% Predicate (and, or, not, like, not like, between, not between, in, not in, any, all, not all).
Agaregate Functions Used in Sgl Query:-
sum ()
max ()
min ()
count ()
avg ()
Order Types:-
s Ascending Order.(A-Z)
¢+ Descending Order.(Z-A)

Wild cards:-
1:-% For all Characters.
2:- (Underscore)For any one characters.

Consider a table:-
EMP(empno,ename,job,sal,deptno,mgr,hiredate,comm)
1:-To display all records from employee table;
SQL>select * from emp;
2:-To display employe no,name, job and sal from employee table;
SQL>select empno, ename, job, sal from emp;
3:-To display employe records from employee table who is found salary more than 1500 ;
SQL>select empno, ename, job, sal from emp where sal>=1500;
4:-To display employe records from employee table who is found sal between 1000 and 2500 ;
SQL>select empno, ename, job, sal from emp where sal between 1000 and 2500;

5:-To display employe records from employee table whose job is clerk,salesman,president

SQL>select empno, ename, job, sal from emp where job
in(‘CLERK’,’"SALESMAN’,”PRESIDENT");

6:-To display employe records from employee table whose job is not clerk, salesman, president

SQL>select empno, ename, job, sal from emp where job
not in(‘CLERK’,’SALESMAN’,”PRESIDENT");

7:-To display employe records from employee table whose name begin with ‘F’;



SQL>select empno, ename, job, sal from emp where ename like ‘F%’;
8:-To display employe records from employee table whose name not begin with ‘F’;
SQL>select empno, ename, job, sal from emp where ename not like ‘F%’;
9:-To display employe records from employee table whose name begin with ‘F’* or ‘J’;
SQL>select empno, ename, job, sal from emp where ename like ‘F%’ or ename like ‘J%’;
10:-To display employe records from employee table ascending order by name.
SQL>select empno, ename, job, sal from emp order by ename asc;
11:-To display employe records from employee table descending order by name.
SQL>select empno, ename, job, sal from emp order by ename desc;
12:-To display total salary, average salary and maximum salary in each department.

SQL>select sum(sal) Total_sal,avg(sal) Average,max(sal) Maximum ,deptno from emp
group by deptno;

13:-To display total salary, average salary and maximum salary in department 20.

SQL>select sum(sal) Total _sal,avg(sal) Average,max(sal) Maximum ,deptno from emp
group by deptno having deptno=20;

14:-To display total records, Minimum salary in department 20.

SQL>select count(*) Total _Record, min(sal) Minimum ,deptno from emp group by deptno
having deptno=20;

15:-To display employee records whose name begin with any character,second character must
be ‘A’ and remaining are any characters.
SQL>select empno, ename, job, sal from emp where ename like © A%’ ;
Example Based on Nested Sgl Query:-
Syntax:-
Select <coll>, <col2>, <col3>... from <table Name>
Where <col_any>=(select <col_any> from <table Name>
Where <col_any>=(select <col any> from <table Name>
Where <col_any>=(select <col _any> from <table Name>

)%

16:- To display employee records whose job is same as job of ‘JAMES’.

SQL>select empno, ename, job, sal from emp where job= (select job from emp where
ename="JAMES");



17:- To display employee records who is found highest salary.
SQL>select empno, ename, job, sal from emp where sal= (select max(sal) from emp);

18:- To display employee records who is found lowest salary.
SQL>select empno, ename, job, sal from emp where sal= (select min(sal) from emp);

19:- To display employee records who is found highest salary or lowest salary.

SQL>select empno, ename, job, sal from emp where sal= (select max(sal) from emp)
or sal= (select min(sal) from emp);

20:- To display employee records who is found second highest salary .

SQL>select empno, ename, job, sal from emp where sal=(select max(sal) from emp where
sal<(select max(sal) from emp));

21:- To display employee records who is found second lowest salary .

SQL>select empno, ename, job, sal from emp where sal=(select min(sal) from emp where
sal>(select min(sal) from emp));

22:- To display employee records who is found second highest salary or second lowest salary .
SQL>select empno, ename, job, sal from emp where sal=(select max(sal) from emp where

sal<(select max(sal) from emp)) or sal=(select min(sal) from emp where sal>(select
min(sal) from emp));

Example Based on Join Query:-

Join:-
To access the data from more than one table simultaneously, In this situation we join
the table.
Types of Join:-
v Equi Join
v Non Equi Join
v' Self Join
v" Quter join
o Left outer join v ()=
o Right Outer join  =...... (+)....

Equi Join:-
Joining two or more table by using a condition.

Example:-
EMP (Empno, ename, job, Sal, Deptno, mgr, comm, hiredate)

DEPT(Deptno,LOC,Dname)

23:- To display employee records with there department name.



SQL>select emp.empno,emp.ename, emp.job, dept.dname,dept.loc from emp,dept
where emp.deptno=dept.deptno;

Non Equi Join:-
Joining two or more table without using any join condition.

24:- SQL>select emp.empno,emp.ename, emp.job, dept.dname,dept.loc from emp, dept;
Self Join
Joining a tables with itself by using a join condition.

25:- To display employee name with his/her boss name.

SQL>select e.ename Employe,m.ename Manager from emp e,emp m
where e.mgr=m.empno;

Quter Join:-
Joining two tables with a join condition having symbols
.. (P)=.....(Left) or =...... (+).... (Right)

Example of Left Outer Join
26:- To display employee records which must have department.

SQL>select emp.ename employee,dept.dname Department from emp,dept
where emp.deptno(+)=dept.deptno;

27:- To display employee records which not necessarily having department.

SQL>select emp.ename employee, dept.dname Department from emp,dept
where emp.deptno=dept.deptno (+);

Example Based on Union, Intersect and minus

28:- Union:-

SQL>select empno,ename from emp
union

select empno,ename from emp1;
29:-Intersect:-

SQL>select empno,ename from emp
intersect

select empno,ename from emp1;
30:-minus:-

SQL>select empno,ename from emp
minus

select empno,ename from empl;

View:- Most Important
It is an object which maps one or more tables known as virtual tables, also called views.




Uses of Views:-
v" For the data security.
v" To reduce redundancy.
v To make query easy.
v To allow data independence.
v To prevent different views of same data.

Types of Views:-
v Simple View
v Composite View/Complex View

Simple View:-
The view based on a single table contains no function or group of data and it can
perform DML statement.

Syntax:-
Create view <view_name> as

Select <columnl1>, < column 2>, < column 3>... from <table Name>
Where <Criteria_Expression>
Order by <Column_name> asc|desc;
Composite View:-

It is based on multiple tables can contains functions and group by clause but does not
always allow DML statement.

Syntax:-
Create view <view_name> as
Select < columnl1>, < column2>, < column3>... from <table Name>
Where <Criteria_Expression>
<Aggregate_Column_name>
Order by <Column_name> asc|desc;

Restriction for complex view:-

v" This can not remove a row if the view contains an aggregate function group by clause and
distinct keyword.

v" It can not modify a row if it contains aggregate function group by clause distinct key word and
column defined by the expression.

v' It cannot add data if it contains aggregate function group by clause, distinct key word, column
defined by the expression and if there are not null column in the base table are not included in
the view.

Example Simple View:-
SQL>create view viewl as select empno, ename, job,sal from emp where sal>=1000;

Insertion through view in master/Base table:-

SQL>insert into viewl values(&no,'&name','&job’,&sal);



Example Composite View:-

1:- SQL>create view view?2 as select emp.empno,emp.ename, emp.job,
dept.dname,dept.loc from emp,dept where emp.deptno=dept.deptno;

2:- SQL>create view view3 as select sum(sal) Total sal,avg(sal) Average,max(sal)
Maximum ,deptno from emp group by deptno;

Index:- Most Important
An index is an object based on column or columns of the table which having an ordered list
of the contents of columns.

Uses of index:-
v" Increase the performance of database.
v" Faster searching of records.

Types of Index:-
v Simple index based on single column.
v Composite index based on multiple column.

Syntax of Simple Index:-
SQL>create index <index_Name> on <Table_Name>(<column_name>);

Example Simple Index:-

SQL>create index emp_index on emp(empno);
SQL>select empno, ename, job, sal from emp where empno>=110;

Syntax of Composite Index:-

SQL>create index <index_Name> on
<Table Name>(<column namel>,<column name2>...);

Example Composite Index:-

SQL>create index emp_index on emp(empno,deptno);
SQL>select empno, ename, job, sal, deptno from emp where empno>=110 and deptno
in(10,20);

How to drop Index:-

SQL>Drop index <index_name>;
How to Display Date of System:-

SQL>select sysdate from dual;

Note:-Dual is a dummy table consist of single column



How to Perform calculation:-
SQL>Select 2*3+5*7 Resultl,6/7+8/3 Result2 from dual,

To display employee records increasing 20% of salary of each employee.
SQL>select empno, ename, sal, sal*1.2 increase_salary from emp;
Block diagram of P/L. SOL Programming:-

(Procedure Language Structure Query Language):-
It is used to execute multiple SQL statement and control inside process of data.

Parts of P/L. SOL :-
v Declaration Section.
v Execution Section.
v' Exception Handling (Optional).

Declaration Section:-

In the declaration section we declare the values, constant and initialize the variables.
Execution Section:-

This section is also known as body of P/L SQL which exist in between begin & end.

In this section we pass the sql statements.
Exception Handeling:-

In this section we declare the exception to handle the errors executed by the body of the

program.
Syntax:-
declare  <variable> <data_type>;
begin
[ Exception ]
end;

Example:- 1 (Addition Of two Numbers)

declare

varl number(5):=&a;

var2 number(5):=&b;

var3 number(5);

begin

dbms_output.put_line('Enter First Number='||varl);
dbms_output.put_line('Enter Second Number='||var2);
var3:=varl +var2;

dbms_output.put_line('Sum of Two Numbers='||var3);
end;

Sql>Set serveroutput on;
Sql>/
Example:- 2 (Product and Division of two Numbers)



declare

varl number(5,1):=&a;

var2 number(5,1):=&b;

var3 number(5,1);

vard number(5,1);

begin

dbms_output.put_line('Enter First Number='||varl);
doms_output.put_line('Enter Second Number='||var2);
var3:=varl /var2;

doms_output.put_line('Division Of Two Numbers='||var3);
var4:=varl*varz,;

doms_output.put_line("Product Of Two Numbers='||var4);
end;

Example:- 3 (Area of circle and Sphere)

declare

r number(5,1):=&r1;

pi number (5,1):=3.14;

area_circle number(5,1);

area_sphr number(5,1);

begin

doms_output.put_line("Enter radious='||r);
area_circle:=pi*r*r;

doms_output.put_line("‘Area of Circle='|area_circle);
area_sphr:=4/3.0*pi*r*r*r;

doms_output.put_line("‘Area of Sphere='||area_sphr);

end;

Example:- 4 (Area of Triangle)

declare

sidel number(5,1):=&a;

side2 number(5,1):=&b;

side3 number(5,1):=&c;

s number(5,2);

Area_Triangle long(9,5);

dbms_output.put_line('Enter First side of triangle="|| sidel);
dbms_output.put_line('Enter Second side of Triangle="||side2);
dbms_output.put_line('Enter Third side of Triangle="||side3);
s:=( sidel+ side2+ side3)/2;

Area_Triangle:=sqrt(s*( s- sidel)*( s- side2)*( s- side3));
dbms_output.put_line('Area of Triangle="|| Area_Triangle);
end,;

Example:- 5 (Leap Year)

declare

year number(5,1):=&y;

begin

dbms_output.put_line('Enter year='|| year);
If mod(year,4)=0 then
dbms_output.put_line('Leap year");



end if;

iIf mod(year,4)!=0 then
dbms_output.put_line('Not Leap year");
end if;

end;

Example:- 6 (Odd/Even)

declare

n number(5,1):=&n1;

begin

doms_output.put_line('Enter number='|| n);
If mod(n,2)=0 then
dbms_output.put_line('Even Number');
else

dbms_output.put_line("Odd Number *);
end if;

end;

Example:- 7 (Example based on database)
%type For One Value
%rowtype For one tuples

declare

varl emp%rowtype;

var2 emp%rowtype;

begin

select * into varl from emp where empno=7369;
doms_output.put_line(varl.empno||" '||varl.ename|| ‘||varl.sal);
end;

Example:- 8 (Example based on database)

declare

no emp.empno%type;

name emp.ename%type;

begin

select empno,ename into no,name from emp where empno=7369;
dbms_output.put_line(no||' '||name);

end:
if-then-else-statement
if<condition> then
<Action>
else
<Action_false>
end if;
Example:- 9
declare

year number(5,1):=&y;



begin

doms_output.put_line('Enter year='|| year);
If mod(year,4)=0 then
doms_output.put_line(‘'Leap year');

else

dbms_output.put_line('Not Leap year");
end if;

end;

Nested if-else Statement:-

if<condition> then
<Action>

elsif<condition> then
<Action>

else
<Action>

End if;

Example: - 10 (Grading System)

declare

h number(6):=&h1;

e number(6):=&el;

m number(6):=&m1;

p number(6):=&p1;

¢ number(6):=&c1;

tot number(6);

per number(6,2);

begin

doms_output.put_line('Enter Marks Obtained in Hindi='||h);
doms_output.put_line("Enter Marks Obtained in English="[le);
doms_output.put_line("Enter Marks Obtained in Maths='||m);
dbms_output.put_line('Enter Marks Obtained in Physics='||p);
dbms_output.put_line('Enter Marks Obtained in Chemistry='||c);
tot:=(h+e+m+p+c);

per:=tot/5.0;

if(per>=75) then

dbms_output.put_line('A Grade'||"'||'Tot='||tot||" '||'Per="||per);
elsif(per>=60 and per<75) then

dbms_output.put_line('B Grade'||" ||'Tot="||tot||" '||'Per="||per);
elsif(per>=45 and per<60) then

dbms_output.put_line('C Grade'||" ||'Tot="||tot||" '||'Per="||per);
elsif(per>=33 and per<45) then

doms_output.put_line('D Grade'||"'||'Tot='|tot||' '||'Per="||per);
else

doms_output.put_line('E Grade'||" ||'Tot="|tot||' ||'Per="||per);
end if;




end;

Example:- 11(Largest of any Three Numbers)
declare

a number(6):=&ai,;

b number(6):=&b1;

¢ number(6):=&c1,;

begin

doms_output.put_line('Enter a='||a);
doms_output.put_line('Enter b='||b);
doms_output.put_line('Enter c='||c);

if(a>b and b>c or a>b and c¢>b) then
dbms_output.put_line('A is the Largest Number?);
elsif(b>c and c>a or b>c and a>c) then
dbms_output.put_line('B is the Largest Number");
else

dbms_output.put_line('C is the Largest Number");
end if;

end;

Example:- 12 (Series of natural Numbers)
While<condition>
Loop
<action>
End Loop;

declare

i number(5):=1;

n number(8):=&n;

begin

doms_output.put_line("Enter Number='||n);
while(i<=n)

loop

dbms_output.put_line(i);

=i+1;

end loop;

end;

Example:- 13 (Series of Fibonaccie Numbers)

declare

I number(5):=1,;

a number(5):=0;

b number(5):=1;

s number(5):=0;

n number(8):=&n;

begin

doms_output.put_line('Enter Number='||n);
while(i<=n)



loop
dbms_output.put_line(s);
a:=b;

b:=s;

s:=a+b;

I=i+1;

end loop;

end;

Example:- 14 (Finding Factorial Of Any Numbers)

declare

I number(5):=1;

fact number(5):=1;

n number(8):=&n;

begin

doms_output.put_line('Enter Number='||n);
while(i<=n)

loop

fact:=fact™i;

I=i+1;

end loop;

doms_output.put_line(‘factorial of number='|| n ||'='|[fact);
end;

Syntax:-
for <variable> in <begin>..<end>

loop
<action>
end loop;

Example:- 15 (Series _of natural numbers)
declare

I number(5);

n number(8):=&n;

begin

dbms_output.put_line('Enter Number='||n);
foriin 1.n

loop

dbms_output.put_line(i);

end loop;

end,;

Define Cursor in Oracle:-

Cursor is used to access the result set present in the memory. This result set contains the records returned on
execution of a query.



There are two types of cursor:

1. Explicit (user defined cursor).
2. Implicit (predefined cursor). OR

Oracle engine uses private working area to process queries. This work area is called as cursor. The data that is stored
in the cursor is called as Active Data Set.

Implicit cursors (predefined cursor): - The oracle engine implicitly opens a cursor on the server to
process each SQL statement. Implicit cursors are managed by the Oracle engine itself.
Explicit Cursors (user defined cursor): - Explicit Cursors are the cursors created by the user inside
a PL/SQL block. The declare section of a PL/SQL block and used within its executable Section.
What is trigger:-
Oracle allows you to define procedures that are implicitly executed when an INSERT, UPDATE, or
DELETE statement is issued against the associated table. These procedures are called database
triggers.
Types of Triggers:-
1:- Built in Triggers/System Defined Triggers.
2:-User Defined Triggers.
2. 1 Before insert.
2. 2 After insert.
2. 3 Before update.
2. 4 After update.
2. 5 Before delete.
2. 6 After delete.
Syntax of trigger:-
CREATE [OR REPLACE] TRIGGER <trigger_name>
BEFORE|AFTER} {INSERT|DELETE|UPDATE} ON <table_name>
[REFERENCING [NEW AS <new_row_name>] [OLD AS <old_row_name>]]
[FOR EACH ROW [WHEN (<trigger_condition>)]]
<trigger_body>

4GL:- (Fourth Generation Language):-
It is also known as Very high level language.Following basic types of language tools fall into this

category.

Query Language.

Report Generator.

Application Generators.

Decision Support System & Financial Planning.
Some Microcomputer application S/w.

ANANENENAN

Example:-

Oracle

Sql Server
Foxpro

v
v
v
v' LINC



Emp (empno, ename, job, sal, deptno, address).
1:-  Todisplay all employee records.

Select * from emp;
2:- To display empno, ename and job only.

Select empno, ename, job from emp;
3:- To display employee records who is found salary more than 10000.

Select empno, ename, job, Sal from emp where sal>=10000;

5GL.:- (Fifth Generation Language):-
It is also known as HAL(Human Accessible Language) based language.

This language make to smarter.
Example:-LOTUS-1-2-3

How to Solve 4 GL to Help solving problem
v They are much easier to learn use.

v They provide more power full feature.
v' They provide convenient feedback on systematic mistakes.
v" It is much faster than 3GL.

Impact of 4 Gl:-
It deserve management attention such as
v Productivity and s/w development.

v’ Restructuring of the system development process.

v Empasis on DSS and End User Computing.

Relational calculas:-

It is a query system where in queries are expressed as variables and formulas on these
variables.Such formula describe the properties of the required result relation without specifying the

method of evaluating it.It is based on predicate calculas.

Example:-
Ram is a good Student. P(x)
Raheem Is a good Student Q(y)

Ram & Raheem both are good Student. P(X)™Q(Y)

Ram & Raheem both are bad Student. g [P(X)Q(Y)]



Tuple calculas:-
Queries in tuple calculas are expressed by tuple calculas expression.A tuple calculas

expression is of the form
{XFCX)}
Where F is formula, involving X and x represent a set of tuples variables.
Tuple calculas formulas are built from atoms.An atom is either of the forms given below.
Al:-x €R Where r is relation and x is tuple variable.
A2:-xey or xec
Where e is comparison operators (>,>=, <, <=, #, =)
Locking Scheme:-
A lock is a variable associated with each such data item manipulating the value of a lock is

called Locking.The value of a lock variable is used in the locking scheme to control the concurrent

access and manipulation of access data item.Locking is done by lock manager.

There are two types of Locks.
« Exclusive Lock (Write lock or update lock).
++ Shared Lock (Read Lock).

Two Phase Locking:-

It has two phases.
% Growing Phases (The number of locks from 0 to Maximum for transaction)

¢+ Contracting Phases (The number of locks held decreases from Maximum to Zero)

Maximum
: ﬂ"

Database Transaction:-

A transaction is a program unit whose execution may change the contents of a
database.If the database was in consistent state before atransaction,then on the completion of the

execution of the program unit corresponding to the transaction,the database will be consistent



state.This requires that the transaction be considered atomic.It is executed either successfully or in
case of errors.
A transaction can end in three possible ways.

¢+ Successful termination.

++ Suicidal Termination (Rollback Operation).

¢ Murderous termination (Aborted for one reason or many reasons).

Property of Transaction:-

s Atomicity (It will run to completion as an indivisible unit)

¢ Consistency (The database was in consistent state before the start of transaction, then on
termination of a transaction the database will also be in a consistent state).

¢ Isolation (Actions performed by a transaction will be isolated or hidden from outside the
transaction until the transaction terminatation.

++ Durability (A transaction ensures that the commit action of a transaction) on its terminations,

will be reflected in the database.



OK to Commit

Start
Commit

v

Database modify

No error /

/

System Detect Error
Modify

End of
Transaction

v

Error Detect by System initiated
Transaction

v

. Database unmodified
Transaction

Error

v

. Rollback
Initiated

It is usually written to stable storage, contains the redundant data required to recover from

volatile storage failures and also errors discovered by the transaction or database system. It
record following in formations:-

¢ A start of transaction marker.

¢ The transaction identifier.

¢ The record identifier.

¢ The operations performed on the records (insert, delete, modify).
¢ The previous value of modified data.

% Updated value of modify record.

«» Commit transaction marker.



Types of Logs:-
¢ Current Log
o It contains log information (including checkpoint) required for recovery from system
failures involving loss of volatile information.
¢ Archival log
o Itis used for failures involving loss of nonvolatile informations.The log contains
information on all transactions made on the database from the copy of archival copy. It
Is written in chronological order.

Checkpoints:-

A scheme called checkpoint is used to limit the volume of the information that has to be
handled and processed in event of system failure involving the loss of volatile information.
It consist of following:-
¢+ A start of checkpoint record giving the identification
+ All log information from the buffers in the volatile storage is copied to the log on stable
storage.
¢ All database updates from the buffers in the volatile storage are propagated to the physical
database.
¢+ An end of check point record is written and the address of the checkpoint record is saved on

the file accessible to the recovery routine on startup after a system crash.

Note:-Checkpoint signal generated by system timer. There are many types of checkpoint signals.
++ Transaction Consistent Checkpoint Signal.
¢ Action consistent checkpoint signal.

+» Transaction oriented checkpoint signal.



Statistical database:-

A statistical database contains confidential information about individuals (or

organizations), which is used to answer statistical queries concerning totals, averages, numbers with

certain characteristics.

Phases of designing database: -

Phase 1

Phase 2

Phase 3

Phase 4

Phase 5

Phase 6

Phase 7

Definition of problem.

It includes estimates of costs (operational and setup), risks analysis.

Analysis of existing system and procedures.

It includes feasibility study of the proposed solution.

Preliminary Design.

This design is evaluated against the initial requirements. The cycle of steps consisting
of the definition of the problem, procedure analysis and preliminary design is repeated
until a satisfactory design is obtained.

Computing system decision.

This decision may be based on the existing environment. If the database is to be
implemented on an existing computer system, The choice is limited to that for the
DBMS.

Final design.

In this phase, we design E-R model of database.

Implementation And Testing.

It consists of writing and compiling the code for the conceptual and external schemes in
the DDL of DBMS.

Operation and Tuning (Improve performance).

This phase includes, the design is ready for day-to-day operation.

Question:-

QUESTION:-1 What do you understand about database?How manage by DBMS?

QUESTION:-2 What are different types of database model? Explain with suitable examples

and diagram.

QUESTION:-3 What is E-R diagram? Explain with suitable examples

and diagram.



QUESTION:-4 Explain about following elements with examples and diagram

%+ Abstraction.

¢ Generalization.

¢+ Specialization.

« Aggregation.
QUESTION:-5 What are three types of different data views of data and level of DBMS ?
QUESTION:-6 What are different types of database anomalies? How it will optimize of minimize.?

Or

What are different types of normalization Technique

QUESTION:-7 What are twelve rules for RDBMS give by EF codd? Explain with suitable example?
QUESTION:-8 What is integrity rules?Explain with suitable example
QUESTION:-9 What are different types of constraints/Validation rules? Explain with examples.
QUESTION:-10 What are different types of files organizations.?
QUESTION:-11 What is distributed database system?Describe about different types of
fragmentation technique

QUESTION:-12 What is schema and subschema?Exaplain with suitable examples.
QUESTION:-13 Explain about Object Oriented database Design technique?
QUESTION:-14 Write functions of DDL,DML,DCL and TCL with suitable exmples?
QUESTION:-15 What are diffenet types of relational algebra functions?
QUESTION:-16 What is the role of Views and Index in database system?
QUESTION:-17 What is join?Explain different types of join technique with suitable examples?
QUESTION:-18 Write short notes of followings?

% DBTG Set

% 4GL and 5GL

<+ ISAM

<+ VSAM

% Inverted file organization

% Integrity rules
% Coral Rings
% Functional dependency

s+ Decomposition of relations



o
%

*

Cardinality/Arity(Degree)

% Schema

¢ E-R models

s BCNF

¢+ Hash functions
QUESTION:-19 What are different types of users in DBMS?
QUESTION:-20 Prepare complete query technique in SQL?

BCA 10(Windows Programming)

Visual Basic(VB)
It is object based programming language. Which facilitates RAD(Rapid Application development)

based programming.The following structure of windows is used in VB programming.lt is known as

IDE(Integrated Development Environment)
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An integrated development environment (IDE) is a programming environment that has been
packaged as an application program, typically consisting of a code editor, a compiler, a debugger,
and a graphical user interface (GUI) builder.



Or

An integrated development environment (IDE) is a programming environment that has been
packaged as an application program, typically consisting of a code editor, a compiler, a debugger,

and a graphical user interface (GUI) builder. The IDE may be a standalone application or may be
included as part of one or more existing and compatible applications.

VB has the following windows:-

Menu / Toolbar :-

This is the only element of the IDE which is always visible. You use it to select which other

IDE elements to view and to add forms or controls to your project. There are many other
features which we will discuss later.

‘%, Project! - Microsoft Visual Basic [design]

Fle Edit View Project Format Debug Run Query Diagram Tools Add-ns Window Help

B-4-"GH yo s SERFRAN L 00 e
Toolbox :-
General I

The toolbox is simply a library of controls which you can place on your application.
Once you have placed all the controls you need onto your applications forms, you can hide
the toolbox to make room for working in the other elements of the IDE.



http://whatis.techtarget.com/definition/compiler
http://searchwindevelopment.techtarget.com/definition/GUI

om o

Project - Projectl x|

|

@g Project1 (Project1)
=49 Forms
-1 Forml (Formi1}

Project Window:-

This is simply a list of all the forms which make up your VB project. There are several

kinds of forms which we will talk about later.

Forms :-

We add these to our VB application as they are needed. They are the windows which
hold the various controls (buttons, text boxes, etc.) which make up our application.

Code Window: -

Like it's name implies, this is where you type in the code that VB executes. Notice that the
heading of the window indicates with which event the code is associated.

M Project] - Form1 [Code) (= EX
lCommand1 LI ICIick :J
Private Sub Commandl Click() i

| 'code for the CLICK event goes here

End Sub




How we write program in IDE Environment

B[=]E

Example:-1

Private Sub CLICKADD_Click()
Dima, b, ¢ As Integer

a = Val(Textl.Text)

b = Val(Text2.Text)

c=a+hb

Text3. Text=c

End Sub

Working with Msgbox:-

It is used for displaying message on screen.
Syntax:-

msgbox (prompt,as vomsgboxresult)



Example:-2

P ezzage box

Private Sub Commandl_Click()

MsgBox ("Welcome How Are You")

MsgBox ("Varanasi is A holly City")

MsgBox ("India is the second Largest country in population™)
End Sub

Working with Print Command (?):-

Private Sub Command2_Click()
Print "Calculated resultof 2 *4 *5+6 *5="2*4*5+6*5

Print "Welcome"

Print "Sum of 6 and 7=",6 + 7
Print “Square of 6=", 6*6

End Sub



Visual basic Arithmetic Operators:-

<+ Addition
< - Subtraction
X Product

o/ Real Divisio

n

o\ Integer Division

o N Exponentiati

on

+» Mod Remainder/Modulo

Example:-4

Private Sub Command2_Click()

Print "Sum of 5+8=",5+ 8
Print "Product of 5*8=",5* 8
Print "Division of 5/8=",5/8

3+4=7
9-4=5
9*5=45
9/5=1.8
13\5=2
3n2=9

19 mod 8=3

Print "Integer Division 0888888888 8\5=", 8 \5

Print "Exponent of 5°2=",5" 2

Print "Modulo of 13 mod 7=", 13 Mod 7

End Sub

Visual basic Logical Operators:-

B2 And
B or
E& not

Relational Operator:-
El > Greater than.
K< Less Than.

Bll>=  Greater than or Equal.

Bll<=  Less Than or Equal.

Ell<> NotEqual.

Visual basic Variable Types/Data Types:-

» Integer
* Long integer
s Single
% Double

s Currency

2 Bytes
4 Bytes
4 bytes
8 Bytes

8 Bytes

-32768 to 32767.

-2147483648 t0 2147483647.

-3402823E38 To -1.401298 E-45 for negative values.
-79769313486232 E308 to -4.94065645841247E-324 For
Negative values.

4.94065645841247 E-324 t0 1.79769313486232 E 308 for
Positive values.

-922337203685477.5808 to 922337203685477.5807



¢ String 10 bytes  String length 0 to 65400 characters.
+» Variable 16 Bytes for numeric 22 bytes +string length for character
Any of the above.

Operator for Data Types:-

% Integer
& long

! Single

# Double
@ Currency
$ String

Description of toolbox:-

<4—— PictureBox

+— TextBox

< Command Button
checkbo —» ¥ & <—— Option Button

Combobo ™ E8 <+— ListBox
+— VScrollB

' DrivelistB




Table (1): Toolbox controls summary.

Control Description

Pointer Used to interact with controls on the form(resize them, move them, etc.). The pointer is not a
conirol

PictureBox A control that display images or print the result.

Label A control that displays uneditable text to the user.

TexiBox A control for accepting user input, Texthox can also display text,

Frame A control for grouping other controls.

CommandButton | A control that represents a button. The user presses or clicks to initiate an action.

CheckBox A control that provides the user with a toggle choice (checked or unchecked)

OptionBution Option buttons are used in groups where only one at a time can be true.

ListBox A control that provides a list of items,

ComboBox A confrol that provides a short list of 1iems.

HscrollBar A horizontal scrollbar,

VscrollBar A vertical scrollbar.

Shape A control for drawing circles, rectangles, squares or ellipse

Line A control for drawing line,

DrivelisiBox A control accessing the system disk drivers,

DirlistBox A control accessing directories on a sysiem

Filelistbox A control accessing file in a directory

Image A control for displayving images. The images control does not provide as many capabilities as a
piciurebox.

OLE A control for interacting with other window applications.

Timer A control that performs a task at programmer specified intervals. A timer 15 not visible to the

USET.




Text Box

A text Box control, sometimes called an edit field or edit control, displays information entered at design time, entered
by the user, or assigned to the control in code at run time.

Button

Use a Command Button control to begin, interrupt, or end a process. When chosen, a Command Button appears
pushed in and so is sometimes called a push button.

List Box

A List Box control displays a list of items from which the user can select one or more. If the number of items exceeds
the number that can be displayed, a scroll bar is automatically added to the List Box control.

Label:-

A Label control is a graphical control you can use to display text that a user can’t change directly.
Combo Box:-

A Combo Box control combines the features of a text box and a list box. This control allows the user to select an item

either by typing text into the combo box, or by selecting it from the list.

Timer:-
A Timer control can execute code at regular intervals by causing a Timer event to occur. The Timer control, invisible

to the user, is useful for background processing.

Picture Box:-
The primary use for the Picture Box control is to display a picture to the user. The actual picture that is displayed is

determined by the picture property. The picture property contains the file name (and optional path) for the picture file

that you wish to display.

DATA Grid Control:-
The DATAGrid control displays and operates on tabular data. It allows complete flexibility to sort, merge, and format

tables containing strings and pictures. When bound to a Data control, MSFlexGrid displays read-only data.

Date and Time Picker Control:-
A Date and Time Picker (DTP) Control provides a simple and intuitive interface through which to exchange date and

time information with a user. For example, with a DTP control you can ask the user to enter a data and then retrieve

his or her selection with ease.

Option Button /Radio Button:-
An Option Button control displays an option that can be turned on or off.

Image Control:-
Use the Image control to display a graphic. An Image control can display a graphic from an icon, bitmap or metafile,

as well as enhanced metafile, JPEG, or GIF files.

Check Box Control:-
A Check Box indicates whether a particular condition is on or off. We use check boxes in an

application to give users true/false or yes/no options. Because check boxes work independently of

each other, a user can select any number of check boxes at the same time.



Example 5:-

Enter first Mumber:- 45

Enter Second Mumber:- 57.8

Result 0.7785467

ADD SUE MUL |

Public a, b, d1, d2, d3, d4 As Double
Private Sub Commandl_Click()

a = Val(Textl.Text)

b = Val(Text2.Text)

di=a+hb

Text3.Text = d1

End Sub

Private Sub Command2_Click()
d2=a-b

Text3.Text = d2

End Sub

Private Sub Command3_Click()
d3=a*b

Text3.Text = d3

End Sub

Private Sub Command4_Click()
dd=alb

Text3.Text = d4

End Sub

Control Structure/Control Statement:-

VB provides facilities for controlling the order of execution of the statements, which is referred to as flow control
statements/control statements.
There are following categories of flow control statements.

% Decision Control Statement.

% Looping Control Statement.

Decision Control Statement:-

if<criteria/Condition> then
Statement_blocks

end if
Exit_Statement_block



Example 6:-

Enter pear

Check_“ear

Private Sub Commandl_Click()
Dimy As Integer

y = Val(Textl.Text)

If (y Mod 4 = 0) Then

MsgBox ("LEAP YEAR")

End If

If (y Mod 4 <> 0) Then
MsgBox ("NOT LEAP YEAR")
End If

End Sub

if-else-end if control statement
iIf<criteria> then
statement_blocks_True
else
statement_blocks False
end if

Example 7:-

CHECK_MUMBER




Public N As Integer

Private Sub Checknumber_Click()
N = Val(Textl.Text)

If (N Mod 2 =0) Then

MsgBox ("EVEN NUMBER") &N

Else
MsgBox ("ODD NUMBER") &N
End If
End Sub
Nested if-then-elif-endif
if<criterial> then
statement_blocks_Truel
else
if<criteria2>
statement_blocks_true2
else
if<criteria3>
statement_blocks_true3
else
end if
end if
end if
Example 8:-

EMTER HINDI MARES =3

EMTER EMGLISH MARES
46
EMTER MATHS MARES e
EMTER PHYSICS MARES ==
EMTER CHEMISTRY MARES 55

TOTaL MAREKS

FERCEMTAGE MARKES

! CLICK_RESULT |

Public h, e, m, p, ¢, tot, per As Double



Private Sub CLICK_MARKSHEET()
h = Val(Textl.Text)
e = Val(Text2.Text)
m = Val(Text3.Text)
p = Val(Text4.Text)
¢ = Val(Text5.Text)
tot=h+e+m+p+c
per = tot/ 5
Text6.Text = tot
Text7.Text = per
If (per >= 75 And per <= 100) Then
MsgBox ("A Grade") &(“Total marks=") & tot &(“Percentage="") & per
Else
If (per >= 60 And per < 75) Then
MsgBox ("B Grade") &(“Total marks=") & tot &(“Percentage="") & per
Else
If (per >= 45 And per < 60) Then
MsgBox ("C Grade") &(“Total marks=") & tot &(“Percentage="") & per
Else
If (per >= 35 And per < 45) Then
MsgBox ("D Grade™) &(“Total marks=") & tot &(“Percentage=") & per
Else
MsgBox ("E Grade") &(“Total marks=") & tot &(“Percentage=") & per
End If
End If
End If
End If
End Sub

Example 9:-

FIRST NUMBER

BR33

SECOND NUMBER

THIRD NUMBER

| CHECK_LARGEST |

Private Sub Commandl_Click()
Dim A, B, C As Integer

A = Val(Textl.Text)

B = Val(Text2.Text)

C = Val(Text3.Text)



If(A>BAndB>COrA>CAndC>B)Then
MsgBox "A IS LARGEST" & Now
Else
If(B>CAndC>A0rB>AAndA>C)Then
MsgBox "B IS LARGEST" & Now
Else
MsgBox "C IS LARGEST" & Now
End If
End If
End Sub
Select-----end select control statement
It is used for designing and solving choice based problem.
Syntax:-
Select case (<Expression>)
case <valuel>
Statement Blocks1
case <value2>
Statement Blocks2
case <value3>
Statement Blocks3

case else

Statement Blocks False

End select

Example:-10

Private Sub Commandl_Click()
Dim N As Integer
Dim A, B, C1, C2, C3, C4 As Double



N = Val(Textl.Text)
A = Val(Text2.Text)
B = Val(Text3.Text)
Select Case (N)
Case 1

Cl=A+B

Text4. Text = C1
Case 2

C2=A-B

Text4. Text = C2
Case 3

C3=A*B

Text4. Text = C3
Case 4

C4=A/B

Textd. Text=C4
Case Else

MsgBox "Enter correct choice
End Select

End Sub

Example:-11(DAY CODE CONVERSION)

CLICK_CHOICE_RESULT

Project1 E|

WEDMESDAY

Private Sub Commandl_Click()
Dim N As Integer
N = Val(Textl.Text)
Select Case (N)
Case 0
MsgBox "SUNDAY™"



Case 1

MsgBox "MONDAY™
Case 2

MsgBox "TUESDAY™"
Case 3

MsgBox "WEDNESDAY"
Case 4

MsgBox "THURSDAY"
Case 5

MsgBox "FRIDAY™
Case 6

MsgBox "SATURDAY"
Case Else

MsgBox "ENTER CORRECT DAY CODE"
End Select
End Sub

CHOICE BASED PROBLEM

1:-QUADRATIC EQUATION 2 -CHECK YEAR

ENTER CHOICE

ENTER COEFFICIENT OF R°2

ENTER COEFICIENT OF X

ENTER CONSTANT

ENTER ANY YEAR

FIRST ROOT

SECOND ROOT

FRES5_0K

Public CH, YEAR As Integer

Public A, B, C, D, X1, X2 As Double
Private Sub Commandl_Click()

CH = Val(Textl.Text)

A = Val(Text2.Text)

B = Val(Text3.Text)

C = Val(Text4.Text)

YEAR = Val(Text5.Text)
Select Case CH

Case 1
D=B"2-4*A*C

If (D =0) Then
X1=-B/2*A



X2=B/2*A

Text6.Text = X1

Text7.Text = X2

Else

If (D >0) Then

MsgBox ("REAL AND UNEQUAL ROOTS")
X1=-B+Sqgr(D)/2*A
X2=-B-Sqr(D)/2*A

Texto. Text = X1

Text7.Text = X2

Else

MsgBox (" ROOTS ARE IMAGINARY™")
End If

End If

Case 2

If (YEAR Mod 4 =0) Then

MsgBox ("LEAP YEAR")

Else

MsgBox ("NOT LEAP YEAR")

End If

Case Else

MsgBox ("WRONG INPUT CHOICE")
End Select

End Sub

Example:-12(RESULT STATUS)

CLICK_CHOICE_RESLLT

Project1 E|

FIRST AND PASSED

Private Sub Commandl_Click()
Dim N As Integer
N = Val(Textl.Text)
Select Case (N)
Case Is <= 33

MsgBox "FAILED & POOR"
Case 34 To 45



MsgBox "THIRD AND PASSED"
Case 46 To 59

MsgBox "SECOND AND PASSED"
Case 60 To 75

MsgBox "FIRST AND PASSED"
Case 76 To 100

MsgBox "EXCELLENT AND PASSED"
Case Else

MsgBox "ENTER CORRECT DAY CODE"
End Select
End Sub

LOOP/ITERATION/REPITITION:-
It allows the execution of some set of statements repeatedly till either for a known number of times
or till certain conditions are met. There are following five types of looping statements.
Types of Looping Control:-
% DO WHILE LOOP
DO LOOP
DO UNTIL
DO LOOP UNTIL
FOR NEXT

L)

3

*

3

*

R/
‘0

D)

3

*

DO WHILE LOOP

It executes looping body when condition is true. And exit from loop when condition is false.
DO WHILE <CONDITION>
STATEMENT_BLOCKS_TRUE
LOOP
EXIT_STATEMENT_BLOCKS_FALSE

Example:-13(SERIES OF NATURAL NUMBERYS)




Private Sub Commandl_Click()
Dim N, | As Integer

=1

N = Val(Textl.Text)

Do While I <= N

Print I;

I=1+1

Loop

End Sub

Example:-14(SERIES OF FIBONACCIE)

01123581321 34

RN -

CLICK_FIB_SERIES

Private Sub Commandl_Click()
DimN, I, A, B, S As Integer
=1
A=0
B=1
S=0
N = Val(Textl.Text)
Do While | <= N
Print S;
A=B
B=S
S=A
S=A+B
I=1+1
Loop
End Sub
DO LOOP
It executes the statement first and then tests condition after each execution.
Syntax:-



do
Statements;
loop while<criteria>

Example:-15(SERIES OF ODD NUMBER)

1357311

|

| CLCK_ODD_SERIES

Print I;

I=1+2

Loop While I <=N
End Sub

DO ...UNTIL
It executes the statement when condition is false and exit when condition is true.
SYNTAX:-
DO UNTIL <CONDITION>
STATEMENT
LOOP

Example:-16(SERIES OF EVEN NUMBERS)

24681012 14 16 18

CERCEIINE ¢

| CLICK_EVEM_SERIES

Private Sub Commandl_Click()
Dim N, | As Integer

=2

N = Val(Textl.Text)
Do Until I >= N
Print I;

I=1+2

Loop

Print “THANK YOU”:
End Sub



DO LOOP UNTIL <CRITERIA>

It executes the statement first and then checks criteria and performs further execution.
OR
This loop has a condition at the end and the statements are repeated until the condition
IS met. Since the check is at the end the statements are at least executed once.
Syntax:-
do
statement_blocks;
updations;
loop until <criteria>

Example:-17(SERIES OF CORRESSPONDIND PRODUCT NUMBERS)

11 26 24 120 720 5040 403220 362330 2623200

B -

CLICK_MUL_SERIES

Private Sub Commandl_Click()
Dim N, I As Integer
=1

M=1

N = Val(Textl.Text)
Do

Print M;

M=M*I

I=1+1

Loop Until I >=N
End Sub

FOR NEXT LOOP:-
Repeats a group of statements a specified number of times.

Syntax :-

For counter [As datatype] = start To end [Step ]
[ statements ]
[ Continue For ]
[ statements |



[ Exit For ]
[ statements ]
Next [ counter ]

Or
Syntax :-

for <variable>=<Start_Value> to <End_Value> Step [ Incrementation/Decrementation]
Statement_blocks_True

Next <variable>
Statement_blocks_False

Example:-18 Series of following numbers

Private Sub Commandl_Click()
Dim N, I As Integer

N = Val(Textl.Text)
For1=2To N Step 4

Print |

Next |

End Sub

WAP to display following pattern:-

* %
* k%
* k kK

* k k k%

Private Sub Command1_Click()
Dim I, N, J As Integer

N = Val(Textl.Text)
ForI=1ToN Step 1
ForJ=1Tol

Print " * ",

Next J

Print

Next |

End Sub



Programming Based On Database:-

Working with DrivelistBox,DirListBox and FileListBox Control:-

DrivelistBox Control:-
It is drop down list box that will display the list of drives on my computer.It gets all
information from operating system and allows the user to select a drive of his choice.

DirListBox Control:-
A drop down list box that displays a hierarchical list of directories in the current drives.

FileListBox Control:-
It displays all files in the current directory or folder.Allows users to set up search
criteria for files.
Example:-

- Select Drive Name:- [ e ioam] I R
Coiiiiiiiiiiiiiiiiiiiiiiiiiooon belect Any Folder Select Any File
SRR R R R [ T ADDSCCUSDLL  a | -
e L Program Files E'EE'E-:'EE-MDE
................................ M ﬂ:'ll‘lll |Std .
i S| CHANDRA PROJEC
................................ kel CHANDRA_PROJEC
coiroiis s @ Template CYPACK. EXE
................................ 3 Ts.ql DATAYVIEW DLL
S (M pards LARGEST fim
L LINK.EXE
................................ MSDIST10.0LL .
L MSFDEEO.DLL vl
- ... Enter any search Criteria

Private Sub Dirl_Change()
Filel.Path = Dirl.Path
End Sub

Private Sub Drivel Change()
Dirl.Path = Drivel.Drive
End Sub

Private Sub Textl Change()
Filel.Pattern = Textl.Text
End Sub



Private Sub Filel Click()
f=Dirl.Path & "/" & Filel.FileName
Picturel.Picture = LoadPicture(f)
End Sub

Private Sub Form_Load()
Filel.Pattern = "*.*"
End Sub
Database Connectivity with VB:-
¢ Through Data. (MS ACCESS AND ORACLE)
¢ Through ADODC. (MS ACCESS AND ORACLE)
Through Data.

Step 1:-Creation of Table

Click Add Ins Menu =>Visual data Manager > File=>New->Ms Access=>Version 7.0 mdb-> Save
In Drive c: with Name EMP->Press Right Button On Property And Click Create Table=>Write
name of Table and Click Add Field Button=>Type Name of various fields and select data type (Say
Field Empno, Ename,Job,Sal) =>Press Build The Table=>Press Right Button And Click
Open->Click Add->»Enter Various records=>Close Database Windows

Step 2:-Form Design

DELETE MNEXT PREW FIRST

Step 3:-Connection Steps




Select Datal-=>Select Database name from property Windows=> Select And Open Table name(Say
Emp) =>Click Recordsource and Select Emp table from property windows=> Select Empno Text box
-> After Then Select data Source (Datal) from property windows =>» Select Data field And Choose

Empno from property Windows=>similarly we will again do these works for Employee Name, Job
and Salary
Step 4:-Codes for Buttons

Private Sub Add_Click()
Datal.Recordset. AddNew
End Sub

Private Sub Delete_Click()
Datal.Recordset.Delete
End Sub

Private Sub Next_Click()
Datal.Recordset.MoveNext
End Sub

Private Sub First_Click()
Datal.Recordset.MoveFirst
End Sub

Private Sub Prev_Click()
Datal.Recordset.MovePrevious
End Sub

Private Sub Last_Click()
Datal.Recordset.MoveLast
End Sub

Connection Through Adodc(MS ACCESS):-

Step 1:-Creation of Table

Click Add Ins Menu =>Visual data Manager =>File=>New=>Ms Access=>Version 7.0 mdb-> Save
In Drive c: with Name EMP->Press Right Button On Property And Click Create Table=>Write
name of Table and Click Add Field Button=>Type Name of various fields and select data type(Say
Field Empno,Ename,Job,Sal) =>Press Build The Table=>Press Right Button And Click Open=>Click
Add=>Enter Various records=>Close Database Windows
Step 2 :- (Adding ADODC)

Project=>Components=>Microsoft ADO Data Control 6.0 (OLEDB) =>Apply->Close

Step 3:-
Drag and Drop Adodc components on form.



PREV FIRST

Step 4 :- Connection Steps:-

Select Record source from Property Windows=>Type select * from emp=> Apply=>0K->
->Click Connection String from property windows=>Use data Link and Select Table by
Browse->Use ODBC->Select MS Access=>Click Use Connection=>Click Build=> Click Use
Connection->Select table from Build=> Click Select->Select table name And Press
Ok=>Press Ok=>Click test Connection=>Press Ok=>Press Apply and Click OK.

Step 5:-Connection of Textbox with Table Fields(EMP)

Data source <> Adodcl->Data Field=>Select Empno, Ename, Job, and Sal step by step.
Step 6:-Codes for Buttons

Private Sub Add_Click()

Adodcl.Recordset. AddNew

End Sub

Private Sub Delete_Click()

Adodcl.Recordset.Delete

End Sub

Private Sub Next_Click()

Adodcl.Recordset.MoveNext




End Sub

Private Sub First_Click()
Adodcl.Recordset.MovePrevious
End Sub

Private Sub Prev_Click()
Adodcl.Recordset.MoveFirst
End Sub

Private Sub Last_Click()
Adodcl.Recordset.MovelL ast
End Sub

What is MDI:- Multiple-Document Interface (MDI) Applications

The multiple-document interface (MDI) allows you to create an application that maintains
multiple forms within a single container form. Applications such as Microsoft Excel and
Microsoft Word for Windows have multiple-document interfaces.

An MDI application allows the user to display multiple documents at the same time, with each
document displayed in its own window. Documents or child windows are contained in

a parent window, which provides a workspace for all the child windows in the application. For
A child form is an ordinary form that has its MDI Child property set to True. Your application
can include many MDI child forms of similar or different types.

& MDIl MotePad
File  Edit Search Opfions  Window

sl EEEE

<A Untitled

— MWD
W rhspe

L Winirized

CREATING MENUS IN VISUAL BASIC (MDI :-Multiple Document Interface)
STEP1:-




Tools=>Menu Editor (Ctrl+E) =

DTN gttty [5 | MegotistePositon: [ omane =] | 0G0 iiiiiiiiiinin

™ Checked [V Enabled IV visible ™ WindowList

ﬂﬂﬂﬂ Next I Insert | Celete I
== NEW Ctrl+N

=**OPEN Ctrl+0

"SAVE Crl+5

BEDIT

=-CUT Cirl+X

< COPY Crl+C

*"PASTE Clrl+v

STEP2:-

After designing Menu =>Press Ok Button
EEX

MEW  Terl+M
OFEM Terl4i
SOWE  Terl+5

Connection Through Adodc(ORACLE):

STEP1:-
Project=>Components=>Microsoft ADO Data Control 6.0 (OLEDB) =>Apply->Close

STEP2:-

Drag and Drop Adodc components on form.




STEP3 Connection Steps:-
Select Record source from Property Windows=> Type select * from emp=> Apply=>0K

->Click Connection String from property windows=>Use Connection String=>Click Build=>
->Type User name And Password in Data Link Property (Scott/Tiger) =>Click Check box of
allowing saving password=>Click Test Connection=>Click OK->Click Apply=>Click OK

B Data Link Properties [

Frovider Connection ] Adwvanced ] Al ]

Specify the following to connect to Oracle data:
1. Enter a server name:

2. Enter information to log on to the databasze:
Uzer name: |SCEITT

uuuuu

FPassword: |

[ Blank password [w  Allowe zaving passweord

T est Connection

| (] I Cancel Help

STEP4:-Adding Fields In Text Box

Select Text Box (EmpNo) =>Click Data Source (Select ADODC1) =>Select Data Field (Empno) =
Similarly for other text boxes.

STEP5:-Coding

Private Sub Add_Click()
Adodcl.Recordset. AddNew



End Sub

Private Sub Delete_Click()
Adodcl.Recordset.Delete
End Sub

Private Sub Next_Click()
Adodcl.Recordset.MoveNext
End Sub

Private Sub Prev_Click()
Adodcl.Recordset.MoveFirst
End Sub

File Handling:-

Example 1:- Creation of file and adding Textual information
Stepl:-

Add:-Project—Reference—"Microsoft Scripting Runtime”
Step2:-

Form Design

FILE HANDELING

Step3:-
Code on Click of Commands (Create and Add)

Dim fstream As New Scripting.FileSystemObject
Dim ts1 As TextStream
Private Sub Add_Click()
ts1.Write Text2. Text & vbCrLf
End Sub
Private Sub Create_Click()
Set ts1 = fstream.OpenTextFile(Textl. Text, ForWriting, True)
End Sub

Example 2:- Creation of file and Copying Textual information
Stepl:-



Add:-Project—Reference—"Microsoft Scripting Runtime”

Step2:-
Form Design

Create

Step3:-
Code

Dim fstream As New Scripting.FileSystemObject
Dim ts1 As TextStream

Dimts As TextStre
Private Sub copy_Click()

am

Set ts = fstream.OpenTextFile(Textl.Text, ForReading, True)

Set ts1 = fstream.O

penTextFile(Textl. Text, ForWriting, True)

While Not ts.AtEndOfStream
ts1.Write ts.ReadLine & vbCrLf

Wend
End Sub

Private Sub Create_Click()

Set ts1 = fstream.O
End Sub
Functions:-

penTextFile(Textl. Text, ForWriting, True)

Visual basic provides some built in functions that help the programmers to write

efficient programm

es.

Built In Functions in VB:-

+» String Functions.
o Str

Lcase$

Ucase$

Rtrim$

Ltrim$

o Len

o O O O

It convert number to string values.

It convert text string into lowercase.

It Convert into uppercase letters.

It removes unnecessary spaces from right.

It removes unnecessary spaces from left.

It calculate number of characters into string.

+ Financial Functions

o DDB
o FV

o PMT

o PV

«* Numeric Functions

It return depreciation of an assets.

It returns future value of an investment based on periodic constant
payments and a constant interest rates.

It calculates premium based on periodic, constant payments and
constant interest rate.

It returns the present value based on periodic, constant payments to
be paid in the future and a constant interest rate.



o Val It convert character string to number.
o CLng It convert number into long.

o Ceur It convert number to currency.

o CDbl It convert number to double.

o CSgn It convert number to single.

Example:-1 Calculation of length of text string

Private Sub Commandl_Click()
Dim str As String

Dim m As Integer

str = Textl.Text

m = Len(str)

Print "length of string=", m

End Sub

Example:-2 Conversion of upper to Lower and Vice Versa




Public str As String

Private Sub Commandl_Click()
str = Textl.Text

MsgBox UCase(str)

End Sub

Private Sub Command2_Click()
MsgBox LCase(str)

End Sub

Code:-

Dimp, n, r, prem, futur As Double
Private Sub Click_FV_Click()
futur = FV(r / 100, n, prem)
Text5.Text = futur

End Sub

Private Sub Click_PMT_Click()
p = Val(Textl.Text)

r = Val(Text2.Text)

n = Val(Text3.Text)

prem = Pmt(r / 100, n, p)

Text4. Text = prem

End Sub



What Is Form,Form Properties and Form Event:-

Form:-
A form is nothing but a box that contains control objects. It is a window or dialog box that one
creates with VB.

Form Properties:-
It means the characteristics or the variables that describe behavioural characteristics of an object it
contains components or attributes such as color, font, caption or name.

Press F4 Button for Open property Window

Properties — Forml

|F1:|-rrn1 Form Ll
alphabetic ]Categarized ]

Clamel Form 1 .
Sppearance 1 - 3
auktoRedrawv Fals=
EackColar [ aH=000000Fs.
EorderStwle = - Sizabl=

Forml
ZlipConkrols Trus=
—onktrolBox: Trus=
DrSvataode 15 - Copw Pen
DraveSkwle 0 - Solid
O avwiideh 1
Enabled True
FillZolar - EHOOOOOO0O0E:.
FillSktwil= 1 - Transparenk
Fonk M=S Sans Serif
FonkTransparsnt Trus
Fore=Colar Hl =:HS000001 28,
HasCn— True
Heighk Sa00
Help—ormbexktID ]
Icon CIcor)
EewPresiews False
L=Fk [} =
il Pell— o~ [ P lo— — —

Caption

Feturnsfseks the texk displawyed in an
object's kitle bar or belowe an objeck's ican.

Form Events:-
An event is an action like a press key or click of the mouse button etc.Each event has a
particular action to be performed.
Syntax:-
Sub Name
Statements;
End Sub

Example:- S



Private Sub Command2_Click ()
Msgbox (“Welcome In IDE Environment”)
End Sub

Event Name:-

Click
Dbclick
DragDrop
DragOver
KeyPress
Load
MouseMove
Unload
KeyDown
What is control:-

It is a special type of object that one draws on form to enable user interaction with an
application, all objects that appear inside a form are called controls. Any controls must have a
name.and includes some properties.

+* Image control
++ Label Control
¢+ Textbox control
% Command control
+ Line Control
¢+ Shape Control
+* Horizontal control
¢+ Vertical control
¢ Rich Textbox Control
etc
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Controls ] Designers ] Inzertable Object=s ]

FMicrosoft Acktivex Plugin

Microsoft A0 Data Control 6.0 (OLEDE)

FMicrosoft Agent Conkrol 2.0

Microsoft Calendar Conkrol 2007

FMicrosoft Chark Conkrol 6.0 (OLEDE)

Microsoft Common Dialog Conkrol &.0

Microsoft Drata Bound List Controls 6.0

Microsoft Datasrid Conkrol 6.0 COLEDED

FMicrosoft Datalisk Conkrols 6.0 (OLEDE)

FMicrosoft DataRepeater Control 5.0 (OLEDE)

Microsoft DDS

Microsoft DireckAanimation Media Controls

Microsoft Flexarid Conkrol 6.0 |
< | =

[ Selected Items Cnly
-1 WideoSoft wsFlex3 Conkrols
Location: U IR S s wsbem3EYV WSFLEX S O X

| Ok I Cancel

Example:-

Stepl:-Take a form
Steo2:-Drag & drop Image Control
Step3:-Insert Image from image source

Custom Control:-
It is a program that someone has written which can be included in the visual basic
program.There are two types of custom controls

s VBX (Visual basic Extension)

s OCX(OLE custom Extension Controls)

How to Load Custom Control:-

Press Ctrl+T

Example:-
Microsoft Calender Control

Microsoft Chart Control
Microsoft ADO Data Control (OLEDB)
Microdoft Data Control. etc.

Write Complete Step for handling database using ADODC




Step 1:-Creation of Table

Click Add Ins Menu =>Visual data Manager => File=>New=->Ms Access=>Version 7.0 mdb-> Save
In Drive c: with Name EMP->Press Right Button On Property And Click Create Table=>Write
name of Table and Click Add Field Button=>Type Name of various fields and select data type(Say
Field Empno,Ename,Job,Sal) =>Press Build The Table=>Press Right Button And Click Open-=>Click
Add->Enter Various records=>»Close Database Windows

Step 2 :- (Adding ADODC)

Project=>Components=>Microsoft ADO Data Control 6.0 (OLEDB) => Apply->Close

Step 3 :-
Drag and Drop Adodc components on form.

WEXT PREW FIRST

Step 4 :- Connection Steps:-

Select Record source from Property Windows=>Type select * from emp=>Apply->0OK=>
=>Click Connection String from property windows=>Use data Link and Select Table by
Browse=>Use ODBC->Select MS Access=>Click Use Connection=>Click Build=>» Click Use
Connection->Select table from Build=> Click Select->Select table name And Press
Ok=>Press Ok=>Click test Connection=>Press Ok->Press Apply and Click OK

Step 5:-Connection of Textbox with Table Fields(EMP)




Data source = Adodcl->»Data Field->Select Empno, Ename, Job, and Sal step by step.
Step 6:-Codes for Buttons
Private Sub Add_Click()
Adodcl.Recordset. AddNew

End Sub

Private Sub Delete_Click()
Adodcl.Recordset.Delete

End Sub

Private Sub Next_Click()
Adodcl.Recordset.MoveNext
End Sub

Private Sub First_Click()
Adodcl.Recordset.MovePrevious
End Sub

Private Sub Prev_Click()
Adodcl.Recordset.MoveFirst
End Sub

Private Sub Last_Click()
Adodcl.Recordset.MoveLast
End Sub

Functions and Procedures:-
Functions:-

It is a set of statements that perform a specific task within a program and return either a
number or a string value.VB has a number of functions. A function must have a name and may or
may not consist of arguments.Function arguments enclosed within parenthesis. There are two
categories of functions.

¢ Built In Functions
o pmt()
fv(0
pv()
Len()
Ucase()
Lcase()

© O O O O

etc.



Example:- Calculation of length of text string

Private Sub Commandl_Click()
Dim str As String

Dim m As Integer

str = Textl.Text

m = Len(str)

Print "length of string=", m

End Sub

+» User defined Functions.

[Private | Public] [Static] Function <function_name>([arguments])
Statement_Blocks
End Function
Example:-
Private Function Add(ByVal x As Integer, ByVal y As Integer) As Integer
Add=x+y
End Function
Private Function pro(ByVal x1 As Integer, ByVal y1 As Integer) As Integer
pro=x1*yl
End Function
Private Sub Form_Load()
Dima, b, c1, c2 As Integer
a=32
b =64
cl = Add(a, b)
c2 = pro(a, b)
MsgBox c1
MsgBox c2
End Sub
Procedures:-
It is a sequence of code statements that performs a specific task within a program but return
no explicit value. it executed as an unit.A procedure begin with a sub statement and end with
an End Sub statement. It performs actions but do not return any values.Function perform
actions and return values.




Syntax:-
[Private | Public] [Static] sub <Procedure_name>([arguments])
Statement_Blocks

End Sub
Example:-1
Sub TestSub()
MsgBox "l am First Procedure”
End Sub

Private Sub Form_Load()
MsgBox "l am executed By form Loading before Procedure calling”
TestSub
MsgBox "l am executed By form Loading after Procedure calling”
End Sub
Example:-2
Private Sub Commandl_Click()
Dim N, | As Integer
=1
N = Val(Textl.Text)
Do While I <= N
Print I;
I=1+1
Loop
End Sub

What Is Data Control:-

Data control functions performed by using Data and Adodc components.
Which is defined below.

Database Connectivity with VB:-
% Through Data. (MS ACCESYS)
% Through ADODC. (MS ACCESS AND ORACLE)

Through Data.

Step 1:-Creation of Table

Click Add Ins Menu =>Visual data Manager =>File=>New->Ms Access=>Version 7.0 mdb-> Save
In Drive c: with Name EMP->Press Right Button On Property And Click Create Table=>Write
name of Table and Click Add Field Button=>Type Name of various fields and select data type(Say
Field Empno, Ename,Job,Sal) =>Press Build The Table=>Press Right Button And Click
Open->Click Add=>Enter Various records=>Close Database Windows

Step 2:-Form Design




EMPLOYEE RECORDS DATABASE

DELETE MNEXT PREY FIRST

Step 3:-Connection Steps

Select Datal=->Select Database name from property Windows=> Select and Open Table name (Say
Emp) =>Click Recordsource and Select Emp table from property windows=>» Select Empno Text box

=> After Then Select data Source (Datal) from property windows =>» Select Data field And Choose
Empno from property Windows=>similarly we will again do these works for Employee Name, Job
and Salary

Step 4:-Codes for Buttons

Private Sub Add_Click()
Datal.Recordset. AddNew
End Sub

Private Sub Delete_Click()
Datal.Recordset.Delete
End Sub

Private Sub Next_Click()
Datal.Recordset.MoveNext
End Sub



Private Sub First_Click()
Datal.Recordset.MovePrevious
End Sub
Private Sub Prev_Click()
Datal.Recordset.MoveFirst
End Sub
Private Sub Last_Click()
Datal.Recordset.MoveLast
End Sub
Through Adodc(MS ACCESS):-

Step 1:-Creation of Table

Click Add Ins Menu =>Visual data Manager > File=>New->Ms Access=>Version 7.0 mdb-> Save
In Drive c: with Name EMP->Press Right Button On Property And Click Create Table=>Write
name of Table and Click Add Field Button=>Type Name of various fields and select data type(Say
Field Empno,Ename,Job,Sal) =>Press Build The Table=>Press Right Button And Click Open-=>Click
Add=>Enter Various records=>»Close Database Windows
Step 2 :- (Adding ADODC)

Project=>Components=>Microsoft ADO Data Control 6.0 (OLEDB) = Apply=>Close

Step 3 :-
Drag and Drop Adodc components on form.

WEXT PREY FIRST

Step 4 :- Connection Steps:-




Select Record source from Property Windows=> Type select * from emp-=>Apply>0OK->
->Click Connection String from property windows=>Use data Link and Select Table by
Browse=>Use ODBC->Select MS Access=>Click Use Connection=>Click Build=>» Click Use
Connection->Select table from Build=> Click Select->Select table name And Press
Ok=>Press Ok=>Click test Connection=>Press Ok->Press Apply and Click OK

Step 5:-Connection of Textbox with Table Fields(EMP)

Data source <> Adodc1->»Data Field=>»Select Empno, Ename, Job, and Sal step by step.
Step 6:-Codes for Buttons
Private Sub Add_Click()
Adodcl.Recordset. AddNew

End Sub

Private Sub Delete_Click()
Adodcl.Recordset.Delete

End Sub

Private Sub Next_Click()
Adodcl.Recordset.MoveNext
End Sub

Private Sub First_Click()
Adodcl.Recordset.MovePrevious
End Sub

Private Sub Prev_Click()
Adodcl.Recordset.MoveFirst
End Sub

Private Sub Last_Click()
Adodcl.Recordset.MovelLast
End Sub

Working With DriveListBox, DirListBox and FileL istBox
Question:-




Write a program to displays all files in the current directory or folder. Allows users to setup
search criteria for files.

5=

Code:-

Private Sub Dirl_Change()
Filel.Path = Dirl.Path

End Sub

Private Sub Drivel Change()
Dirl.Path = Drivel.Drive
End Sub

Private Sub Textl Change()
Filel.Pattern = Textl.Text

End Sub

Visual basic Built In Function Related To files and Folders:-
ChDrive Changed the current logged drive

ChDir Changes The default directory

MKDir Creates a new Directory

RmDir Deletes a directory

Name Renames a file

Kill Deletes a file

FileCopy Copies Source files to destination

FileDateTime Return date and time when the file was modified
GetAttr Returns the attribute of a file as an Integer Value
SetAttr Sets the attributes of a file.

Syntax of ChDrive:-



ChDrive drive
Syntax of ChDir:-

ChDir path
Syntax of MKDir:-

MKDir path
Syntax of RmDir:-

RmDir path
Syntax of kill:-

kill pathname

Common Dialog Control:-
It provides standardization in the interface for all windows compliment
applications, VB has the commonDialog Control. It let us display the following
dialog boxes.
K2 Open a file
Kl Save a file
K2l Set a Color
K2l Set a Font
B2l Print a Document
Method of Common Dialog Box:-
» ShowOpen
» ShowSave
» ShowColor
» ShowFont
» ShowPrinter
» ShowHelp

Example:-

WAP to display File Open dialog Box and changing color dialog box.
Stepl:-

Project—Component—Microsoft Common Dialog Control 6.0
Step2:-

Drag the Microsoft Common Dialog Control 6.0 on form
Step3:-Drag and Drop text Box on Form
Step4:-make two Button say Open and Color
Step5:-Write code on Open and Color




Code:-

Private Sub Commandl_Click()
CommonDialogl.ShowOpen
End Sub

Private Sub Command2_Click()
CommonDialogl.ShowColor

Textl.ForeColor = CommonDialogl.Color
End Sub

Code Changes for Displaying a File Open Dialog Box
The following code demonstrates displaying a File Open dialog box, initialized to the
Program Files directory.

CommonDialogl.InitDir = "C:\Program Files"
CommonDialogl.ShowOpen

OpenFileDialogl.InitialDirectory = "C:\Program Files"
OpenFileDialogl.ShowDialog()

Code changes for Displaying a File Save Dialog Box
'Visual Basic 6.0
' Uses a CommonDialog control.
CommonDialogl.InitDir = App.Path
CommonDialogl.ShowSave

'Visual Basic

' Uses a SaveFileDialog component.

SaveFileDialogl.InitialDirectory = My.Application.Info.DirectoryPath
SaveFileDialogl.ShowDialog()

Code changes for Displaying a Print Dialog Box
'Visual Basic 6.0

" Uses a CommonDialog control.
CommonDialogl.FileName = App.Path & "MyFile.txt"
CommonDialogl.ShowPrinter



"Visual Basic

" Uses PrintDocument and PrintDialog components.
PrintDocumentl.DocumentName = My.Application.Info.DirectoryPath _
& "MyFile.txt"

PrintDialogl.Document = PrintDocumentl

PrintDialogl.ShowDialog()

Working with RichText Control:-

It provide the necessary interface to the user.We are able to create a small application
that would allow the user to create a new file or open an existing file,add text to it,save the changes
and print the content of the file as well.We could also change the font size,font color of the text
etc.By This control we create own word processor.

Stepl:- Add Microsoft Rich text Box Control6.0

Step2:- Select the control tab in the component box

Step3:- Double click on the Microsoft rich textbox control item from the list of
component

Step4:- close the component box

Stepb:- draw the following controls on the form

Far calling Font dialog Box:-
Commondialogl.showFont

Richtextbox1. selFontname = Commondialogl.FontName
Far calling Color dialog Box:-
Commondialogl.showColor

Richtextbox1. selcolor = Commondialogl. color
ActiveX:-

It provides facility to import data from one application to another application. And also
facilitates following features.
Or
ActiveX controls are COM components or objects you can insert into a Web page or
other application to reuse packaged functionality someone else has programmed.
B2l To be able to make changes in the imported data.
B2 To be place different types of data or object in one document.
K2l 1t facilitates DDE(Dynamic data Exchange).
K2l 1t also allowed one application to send commands to another applications.

Conclusion:-
This technology inbuilt in VB was not very successful and gave way to newer
technology. Next came OLE (Object Linking and Embedding).
Under This technology, one document could display an object from different
applications.

OLE:-

It is a way of attachment of word file in the form of linked object or embedded object. In case
linked object original file must be change or affected and in the case of embedded object,
original file does not change or affect. A word document that accepts or requests an object is
called as client or container.The application that provides an object is called the server.




In other words OLE provide a mechanism by which a container application can execute
commands in the server application .It allows to container application export or transfer data
from the objects to another application.
Note:-
ActiveX is a OLE of type of some extension.Some properties of ActiveX controls are:-

K Properties:-Like BackColour, Font, Resize, Paint, etc.
K Events:-Click, MouseMove, Keypress etc.
K& Methods:-The code associated with the control

Connection:-
There are following three types of connectivity of database with VB application.
B2 DAO Data access Object
B2 ADO ActiveX data Object
EARDO Remote data Object

Step:-1 First we include Reference:-Microsoft ActiveX data Object 2.1 Library

Procedures & functions in Visual Basic:-

We use procedures and functions to create modular programs. Visual Basic statements are grouped
in a block enclosed by Sub, Function and matching End statements. The difference between the two
is that functions return values, procedures do not.

A procedure and function is a piece of code in a larger program. They perform a specific task. The
advantages of using procedures and functions are:

e Reducing duplication of code

e Decomposing complex problems into simpler pieces
o Improving clarity of the code

e Reuse of code

e Information hiding

Procedures

A procedure is a block of Visual Basic statements inside Sub, End Sub statements. Procedures do not
return values.

Option Strict On

Module Example

Sub Main ()



SimpleProcedure ()
End Sub

Sub SimpleProcedure ()
Console.WriteLine ("Simple procedure")
End Sub

End Module

This example shows basic usage of procedures. In our program, we have two procedures.
TheMain() procedure and the user defined SimpleProcedure(). As we already know,
the Main()procedure is the entry point of a Visual Basic program.

SimpleProcedure()

Each procedure has a name. Inside the Main() procedure, we call our user
definedSimpleProcedure() procedure.

Sub SimpleProcedure()
Console.WriteLine("Simple procedure™)
End Sub

Procedures are defined outside the Main() procedure. Procedure name follows the Sub statement.
When we call a procedure inside the Visual Basic program, the control is given to that procedure.
Statements inside the block of the procedure are executed.

Procedures can take optional parameters.
Option Strict On

Module Example

Sub Main ()
Dim x As Integer = 55
Dim y As Integer = 32

Addition (x, V)

End Sub

Sub Addition (ByVal k As Integer, ByVal 1 As Integer)
Console.WriteLine (k+1)

End Sub

End Module

In the above example, we pass some values to the Addition() procedure.

Addition (x, V)

Here we call the Addition () procedure and pass two parameters to it. These parameters are two Integer values.



Sub Addition (ByVal k As Integer, ByVal 1 As Integer)
Console.WriteLine (k+1)
End Sub

We define a procedure signature. A procedure signature is a way of describing the parameters and
parameter types with which a legal call to the function can be made. It contains the name of the
procedure, its parameters and their type, and in case of functions also the return value.

The ByValkeyword specifies how we pass the values to the procedure. In our case, the procedure
obtains two numerical values, 55 and 32. These numbers are added and the result is printed to the
console.

Functions

A function is a block of Visual Basic statements inside Function, End Function statements.
Functions return values.

There are two basic types of functions. Built-in functions and user defined ones. The built-in
functions are part of the Visual Basic language. There are various mathematical, string or conversion
functions.

Option Strict On

Module Example
Sub Main ()
Console.WritelLine (Math.Abs (-23))
Console.WritelLine (Math.Round (34.56))
Console.WriteLine ("ZetCode has {0} characters",
Len ("ZetCode"))
End Sub

End Module

In the preceding example, we use two math functions and one string function. Built-in functions help
programmers do some common tasks.

In the following example, we have a user defined function.
Option Strict On
Module Example

55
32

Dim x As Integer
Dim y As Integer

Dim result As Integer
Sub Main ()

result = Addition (x, V)
Console.WritelLine (Addition (x, Vy))

End Sub



Function Addition(ByVal k As Integer,
ByVal 1 As Integer) As Integer
Return k+1
End Function

End Module

Two values are passed to the function. We add these two values and return the result to
the Main()function.

result = Addition (x, V)

Addition function is called. The function returns a result and this result is assigned to the result
variable.

Function Addition (ByVal k As Integer,

ByVal 1 As Integer) As Integer
Return k+1
End Function

This is the Addition function signature and its body. It also includes a return data type, for the
returned value. In our case is is an Integer. VValues are returned to the caller with the Returnkeyword.

Recursion

RECURSIVE FUNCTIONS

A recursive process is a process that calls itself. A recursive function is a function that calls
itself (with different arguments).-

Recursion is a powerful problem-solving tool. It can break a complex problem into simpler
ones. It is available in many modern languages such as VB.

Function Factorial(n)
Dim i As Integer
Factorial = 1
Fori=1Ton

Factorial = Factorial * i
Next 1
End Function
Program:-
Public N, N1, I As Integer
Private Sub FACT _Click()
N = Val(Text1.Text)
Factorial (N)
End Sub
Function Factorial(N1)
Factorial = 1
ForI=1To N1

Factorial = Factorial * I



Print I, "=", Factorial
Next 1
End Function

What is Array:-

A two dimensional array is a table of items that make up of rows and columns. The format
for a one dimensional array is Array Name(x), the format for a two dimensional array is Array
Name(x,y) and a three dimensional array is Array Name(x,y,z) . Normally it is sufficient to use one
dimensional and two dimensional arrays.

Example of One dimensional Array

Student Name Name(1) Name(2) Name(3) Name(4)

Example of Two Dimensional Array

Name(1,1) Name(1,2) Name(1,3) Name(1,4)
Name(2,1) Name(2,2) Name(2,3) Name(2,4)
Name(3,1) Name(3,2) Name(3,3) Name(3,4)

Declaring Arrays
In general format to declare a one dimensional array is as follow:
Dim array_Name (subscript variable) as data_Type

Examples:-

Dim CusName(10) as String

Dim Count (100 to 500) as Integer
Program:-1

Dim studentName(10) As String
Dim num As Integer

Private Sub addName()
Fornum=1To 10
studentName(num) = InputBox("Enter the student name"”, "Enter Name", ", 1500, 4500)
If studentName(num) <> """ Then
Form1.Print studentName(num)
Else

End

End If

Next

End Sub

Program:-2

Dim studentName(10) As String
Dim num As Integer



Private Sub addName( )

Fornum=1To 10

studentName(num) = InputBox("Enter the student name")
List1.AddItem studentName(num)

Next

End Sub

Private Sub Start_Click()

addName

End Sub

Program:-3

Private Sub cmdAdd_Click()

Dim i, j, r1, c2 As Integer

Dim a(), b(), c() As Integer

rl = Val(InputBox(“Enter rows”))

cl = Val(InputBox(“Enter columns™))
ReDim a(r1, c1)

Textl.Text = “First Matrix is :” & vbNewLine
Fori=1Torl

Forj=1Tocl

a(i, j) = Val(InputBox(“Enter Elements”))
Textl.Text = Textl. Text & a(i,j) &
Next

Textl.Text = Textl.Text & vbNewLine
Next

ReDim b(r1, cl)

Textl.Text = Text]l.Text & “Second Matrix is :” & vbNewLine
Fori=1Torl

Forj=1Tocl

b(i, j) = Val(InputBox(“Enter Elements”))
Textl.Text = Textl.Text & b(i, j) & ””
Next

Textl.Text = Textl.Text & vbNewLine
Next

ReDim ¢(rl, c1)

Textl.Text = Textl.Text & “Addition of Two Matrix is :” & vbNewLine
Fori=1Torl

Forj=1Tocl

c(i, j) = a(i, j) + b(i, j)

Textl.Text = Textl. Text & c¢(i, j) &7 ”

Next

Textl.Text = Textl.Text & vbNewLine

Next

End Sub

Private Sub cmdClear_Click()
Textl.Text =
End Sub

Private Sub cmdExit_Click()
Unload Me
End Sub

Question:-WAP to display a series of prime numbers.



Public p, n, i As Integer
Private Sub Prime_Series_Click()
p=1

Print "Prime; Numbers; are:"
Forn=1To 100
Fori=2Ton-1

If n Mod i=0 Then

p=0

Exit For

Else

p=1

End If

Next
Ifp=1Then
Print n;

End If

Next
End Sub
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